xbox.com - automatically loads in wrong language when "en" has highest q value

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
12 years ago
3 years ago

People

(Reporter: Matt Pies, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3

When I try to load www.xbox.com, Camino loads either the Japanese version of the site or some other Asian localization of the webpage. Example: I type in "www.xbox.com" and it takes me to "http://www.xbox.com/zh-TW/" on a G5 iMac (OS 10.3) and the Japanese site on my iBook (OS 10.4). However, when I use Firefox or Safari, it takes me to the English (US) site like it should "www.xbox.com/en-US/" I have tried deleting my cookies and cache to no avail.

Reproducible: Always

Steps to Reproduce:
1.open camino
2.load address "www.xbox.com"
3.

Actual Results:  
It always takes me to an Asian version of the page (Japanese, Chinese, etc).
Ex:
http://www.xbox.com/zh-TW/
http://www.xbox.com/ja-JP/

Expected Results:  
Gone to the English (US) version like Firefox or Safari automatically do.

ex:
http://www.xbox.com/en-US/

This has happened to me with EVERY version of Camino I've used (1.0.0-1.0.3 and other nightly builds).
WFM on 10.3.9 and a recent nightly, but haven't we seen this before? cl?

Comment 2

12 years ago
It took *me* to de-DE!

But yeah, this looks really familiar.
What HTTP headers is Camino sending? xbox.com redirects based on the Accept-Language header.
(Reporter)

Comment 4

12 years ago
I went to about:config and found the option "intl.accept_languages" and it was set to:

en,ja,fr,de,es,it,nl,sv,no,da,fi,pt,zh-cn,zh-tw,ko

I changed it so it is now set to just "en" and now xbox.com loads to the en-US site.  It seems as if there is no default language that it sends and instead is sending a random one from that list.

Updated

12 years ago
Depends on: 300905
I think the other bug explains it, but as an executive summary, we're using the order of languages in the Mac OS X System Prefs (like Safari) to do populate accept-lang (and, after initially selecting which language is at the top of the list when setting up a new Mac, many users never change the list.  en-US users won't change things unless they are bilingual :P and unfortunately "English" in Mac OS X defaults to the generic "en").

Since these sites don't recognize "en", they're falling back to the highest-q language they do recognize (and since I specifically added "US English" to the top of my System Prefs language list, I get en-US in my accept-lang and don't see the bug).

This is kind-of a dupe of 300905, but since we've kicked other sites to TE, I'll do that here, too (though we may simply have to change things in 300905 to work-around all the brain-dead servers).

smontagu, thanks for the heads up :)

Matt: there is actually a "default", you just can't see it from the intl.accept_langs pref itself (it *was* "en" in your original string; there's a q factor computation not shown in the pref listing itself but sent with the actual header).
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Page Layout → English US
Ever confirmed: true
Product: Camino → Tech Evangelism
QA Contact: page.layout → english-us
Conforming to TE summary rules; sorry for bugspam.
Summary: xbox.com automatically loads in an asian language → xbox.com - automatically loads in wrong language when "en" has highest q value
*** Bug 323670 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
Specifically, I get http://www.xbox.com/ja-JP/ when I load www.xbox.com.  I also can not alternately browse from www.microsoft.com to www.xbox.com.  www.microsoft.com does display correctly and in the correct language.

Comment 9

12 years ago
*** Bug 364080 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 372108

Updated

11 years ago
Duplicate of this bug: 380178
Is this still an issue that requires TE efforts?
I'm thinking no, let's close this bug and enjoy some Titanfall..
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.