ALWAYS crashes when printing/previewing SOME KIND of pages

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: p.furiesi, Unassigned)

Tracking

1.8 Branch
x86
Linux
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060830 Firefox/1.5.0.7 (Debian-1.5.dfsg+1.5.0.7-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060830 Firefox/1.5.0.7 (Debian-1.5.dfsg+1.5.0.7-1)

Generally, Firefox prints with no problems. But for some kind of pages (as this one!), it sends data correctly to the printer, then crashes.
Same behaviuor for print preview: the preview window shows up, but Firefox crashes.


Reproducible: Always

Steps to Reproduce:
1. Open a page that causes FF to crash (i.e., this "bug submission" page).
2. Choose from menu: File -> Print or File -> Preview


Actual Results:  
For File -> Print: page got printed, FF crashed.
For File -> Preview: preview window got up, FF crashed.

Expected Results:  
FF shouldn't crash.

Theme: default.
Printer: default printer - remote EPSON EPL-6200 via CUPS.
(Reporter)

Comment 1

12 years ago
Created attachment 240131 [details]
buildconfig

Comment 2

12 years ago
what user set printer prefs do you have? and what env vars do you have relating to printing?

Comment 3

12 years ago
This could be bug 294879, but it's hard to tell without a stack.
Assignee: nobody → printing
Component: OS Integration → Printing
Product: Firefox → Core
QA Contact: os.integration
Version: unspecified → 1.8 Branch
(Reporter)

Comment 4

12 years ago
(In reply to comment #2)

No env vars relater to printing.
---
/usr/bin/lpstat -a -s   produces the following:
  paashp accepting requests since mer 12 lug 2006 10:40:21 CEST
  paaslaser accepting requests since mer 12 lug 2006 12:45:03 CEST
  system default destination: paaslaser
  device for paashp: usb://hp/officejet%205500%20series?serial=MY54TG101H96
  device for paaslaser: socket://192.168.2.253:9100
---
Printer options (from FireFox "Print" menu:)
  Name: CUPS/paaslaser
  Properties: Size A4, Grayscale, all margins set to 0.04
  No print to file; Range: all; Copies: 1
(Reporter)

Comment 5

12 years ago
(In reply to comment #3)
> This could be bug 294879, but it's hard to tell without a stack.

I'm afraid not. In #294879 is reported FF to crash always when printing. But in my case, FF crashes only on some page; i.e., printing Google's homepage is ok, but Bugzilla pages are not.
I tried to discriminate which kind of pages get FF to crash, with no result.

Comment 6

12 years ago
(In reply to comment #5)

> I'm afraid not. In #294879 is reported FF to crash always when printing. But in
> my case, FF crashes only on some page; i.e., printing Google's homepage is ok,
> but Bugzilla pages are not.
> I tried to discriminate which kind of pages get FF to crash, with no result.

If you write Bug 294897 instead of #294879 you get a nice link, telling you the bug title on hovering.

https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox is personalized to you, contains your address (p.furiesi@tiscali.it) and your saved searches, if any. Do you have 'Saved Searches'? Do they contain any special characters, characters with an accent?
Is this bug page crashing on PrintPreview? Does disabling JS make a difference?


(Reporter)

Comment 7

12 years ago
(In reply to comment #6)

> Do you have 'Saved Searches'? Do they contain any special characters,
> characters with an accent?
> Is this bug page crashing on PrintPreview? Does disabling JS make a difference?

No saved searches, no special chars, no accents. Neither in this page, nor in other ones which cause FF to crash.
Yes, FF crashes on PrintPreview (i.e.: preview window remains open, FF window close).
JS on/off doesn't matter.

Updated

12 years ago
Flags: blocking1.9?

Comment 8

12 years ago
This was reported with version Debian-1.5.dfsg+1.5.0.7-1. It appears we're close to dropping support for Firefox 1.5 if we haven't done it already, and we don't support the debian release in any event. p.furiesi, are you still experiencing this problem, and can you produce it with Firefox 2.0 or the prerelease version of 3.0?
p.furiesi, do you crash also with a new profile / Safe mode and on a recent Trunk build from 
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ ?

Comment 10

11 years ago
please reopen if this still occurs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.