Closed Bug 354349 Opened 13 years ago Closed 13 years ago

If the first font isn't found, secondary fonts don't seem to be used

Categories

(Core :: Graphics, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 352174

People

(Reporter: ispiked, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060926 Minefield/3.0a1

If two fonts are specified in CSS rules, say p { font-family: Helvetica, Arial; } and the first font isn't found, the second font isn't used.

Steps to reproduce:
1. Load the testcase. NB: This testcase assumes you don't have a font installed titled "SomeNoneExistentFont".

The same behavior can be observed when using a <font> tag like: <font face="Helvetica,Arial">text</font>.

Pretty sure this is a regression from bug 339513.
Attached file testcase
See bug 349469 comment 4

*** This bug has been marked as a duplicate of 352174 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
This bug may depend on that bug, but I don't think it's a duplicate.
Status: RESOLVED → REOPENED
Depends on: 352174
Resolution: DUPLICATE → ---
This is a dup of bug 352174.

Because we are not checking whether the font is existing on the system. Pango uses the similar font by its logic if it cannot find the specified font. And we have similar problem, we cannot resolve the alias of font family. They will be fixed by bug 352174 in all platforms.

*** This bug has been marked as a duplicate of 352174 ***
No longer blocks: 339513
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
No longer depends on: 352174
Resolution: --- → DUPLICATE
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061127 Minefield/3.0a1

Masayuki, the testcase above still doesn't pass. Should this bug be reopened?
Testcase passes for me in Windows, I guess something could still be wrong on Linux....

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061126 Minefield/3.0a1 ID:2006112604 [cairo]
Right, but the current bug is caused by the bug of my patch.
So, it's another bug. I'll file a new bug and CC you.
You need to log in before you can comment on or make changes to this bug.