search ignores contents inside textboxes

RESOLVED DUPLICATE of bug 252371

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 252371
13 years ago
11 years ago

People

(Reporter: jwagner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3

Seeing this both in XP, Firefox 1.5.0.7 as well as SuSE 10.1, Firefox 1.5.0.3. 

The search function of the Find: search bar when using Find Next and Find Previous does not look through the contents of textboxes on the page. Assume a web page where the searched word/phrase is only present in a text box. In this case "Highlight all" does successfully highlight the word/phrase inside the textbox, but the Find: textbox background color is reddish and "Phrase not found" text and icon appear, incorrectly indicating no occurences of the word/phrase were found, and neither do Find Next or Find Previous set selection and move caret to the entry inside the textbox.

Reproducible: Always

Steps to Reproduce:
1. go to, for example, http://www.wikipedia.org/ and enter "something" into the textbox on that page (i.e. enter a word that isn't found elsewhere on that web page)
2. Ctrl-F, enter search term "something", and also select Highlight all
3. try Find Next, Find Previous

Actual Results:  
"something" is highlighted by "Highlight all", but Find Next and Find Previous do not find the occurence, and the search bar says Phrase not found

Expected Results:  
"something" is highlighted by "Highlight all", and Find Next will move selection to the text "something" inside the textbox and place the caret at the selection.

In other words, as with "Highlight all" and Find Next / Find Previous for phrases outside textboxes, the search function should work in exactly the same way also for phrases inside textboxes <=> for consistency, all found occurences highlighted by "Highlight all" should behave the same with Find Next / Find Previous.

If current behaviour is per design/specification, consider it very bad and inconsistent design, and please improve.

*** This bug has been marked as a duplicate of 252371 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: Search → Find Toolbar / FastFind
QA Contact: search → fast.find
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.