Closed Bug 354364 Opened 15 years ago Closed 15 years ago

"Highlight all" inside textboxes should not block editing and caret movement inside textbox

Categories

(Toolkit :: Find Toolbar, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 256989

People

(Reporter: jwagner, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.3) Gecko/20060425 SUSE/1.5.0.3-7 Firefox/1.5.0.3

Phrases inside editable textboxes on a web page highlighted via "Highlight all" of the search functionality can not be edited, nor can you move the caret (using keyboard left/right arrow keys) into or over the highlighted phrase. It would be a much smoother experience if the highlighted phrases inside textboxes were editable, loosing their highlighting during edits.

Reproducible: Always

Steps to Reproduce:
1. go to http://www.wikipedia.org/, in the text box there enter "try to edit this"
2. Ctrl-F, search for "edit", and also select "Highlight all"
3. click inside textbox either side of "edit", try to move (w keyboard arrow keys) into or accross highlighted word "edit" or try to place (w mouse) caret inside word "edit", try to edit highlighted text "edit" into something else

Actual Results:  
Caret doesn't move over highlighted word left/right boundaries, highlighted text editing (deleting, adding characters, selecting, etc) not possible

Expected Results:  
Highlighted text behaves like normal text inside editable textbox i.e. caret moves normally and text can be edited

*** This bug has been marked as a duplicate of 256989 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Component: Search → Find Toolbar / FastFind
QA Contact: search → fast.find
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.