Open Bug 354400 Opened 14 years ago Updated 10 years ago

Open file dialogue weirdness

Categories

(Firefox :: File Handling, defect)

2.0 Branch
x86
Windows XP
defect
Not set

Tracking

()

REOPENED

People

(Reporter: ipottinger, Unassigned)

Details

Attachments

(5 files)

I have noticed sometimes the open file dialogue does not display the "Open with" application even though it has been repeated set and at those times the "Do this automatically ..." setting is not respected.  Surprisingly, I can just hit "OK" and everything proceeds as expected.

I don't know enough to file a test case for this but I can attach some screenshots.
Attached image dialogue with weirdness
Attached image download action setting
Attached image change action setting
Attached image LiveHeaders snapshot
I thought bugzilla would add this information automaticly, but it didn't. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060926 BonEcho/2.0 ID:2006092609
There is a simple solution that worked well for me - use OLD FireFox (in my case 1.0.6) and ALL is working as it should. FF properly remember the choice "do not ask again" and that it is.

I wonder why you guys insist on more recent FF, when it is, in fact, not very usable...

It seems to be a known bug, but no-one is willing to do anything with it...

Movie example of the problem:
WMV sample: http://ax2.old-cans.com/Voting_Machine.wmv

(yes, working for me w/o asking all over again in FireFox 1.0.6 - I have set my movies start playing in BSplayer on just click, so... I want this happen w/o the annoying confirmation window... so I can use only FF 1.0.x, seems. From 1.5 up to latest 2.0.x it keep happening...)
Just to add to other experiences recounted here ...

I've used every version of FF and the failure of the download manager to remember "do this automatically..." settings has happened with each and every version from 1.5 onwards. I check each new release and, so far, have consistently had to revert to 1.0.8 to avoid this extremely annoying bug.

1.0.8 has never, repeat, never failed to honour a "do this automatically ..." setting for any filetype.

So the obvious question is what is different about the download manager in subsequent versions which leads to the same files (never mind filetypes) being treated differently?
This looks like bug 331259
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 331259
Reopening since the fix for bug 331259 has had no affect on the symptoms I reported.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2007122105 Minefield/3.0b3pre ID:2007122105
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I have to confirm that using v1.0.8 does fix this bug, hence I have to use it. I can't believe no-one else is bothered enought to say something harshly and loudly, but what the hell...
Neverless, it is possible to get FF 1.5 work with settings created from v1.x and then it works. But as long, as the settings are changed, the MIME file definition stuff get wrong again and FF start asking all over again.
I choose "never ask again" and it keep asking again and again and again...

No fix is yet prodided.

Or - perhaps it is fixed, just it need entire prefsh wipe out...?
Anyone can try it. I definitively will not. I'm happy with v1.0.8 ... it does not ask me twice about any files I using.
Seems still reproducible in FF 3.5.5 on Ubuntu. Several times I click on

https://netbeans.org/bugzilla/attachment.cgi?id=91561

which sends (among other headers):

  Content-disposition: attachment; filename="snapshot-177427.nps"
  Content-length: 262144
  Content-Type: application/nps; name="snapshot-177427.nps"
  Cache-Control: max-age=2592000
  Keep-Alive: timeout=5, max=100
  Connection: Keep-Alive

which looks fine to me. I have previously asked to open this kind of file with  ~/nbopen, my preferred application (a shell script a+x). I get the dialog shown in snapshot (though OK button is enabled). Hitting Enter successfully opens it with nbopen.

Firefox Preferences > Applications shows

NPS file (application/nps) | Use nbopen

which looks fine as well. So I think the bug is that the dialog shows

(X) Open with  [Browse...]

which gives no indication that it is going to correctly open the file using nbopen if you just click OK. Or perhaps the dialog is not supposed to appear at all.
Bug 453455 seems to be describing the same thing but is a lot more popular.
Perhaps the voters here could vote there and mark this one as duplicate?
Not quite a duplicate.  

This bug is about the missing "Open with" application in the dialogue. The disrespect for the "Do this automatically ..." setting is only incidental.
You need to log in before you can comment on or make changes to this bug.