element positioned absolutely via bottom is not in the correct place inside an element with min-height

RESOLVED DUPLICATE of bug 128670

Status

()

Core
Layout: R & A Pos
RESOLVED DUPLICATE of bug 128670
11 years ago
11 years ago

People

(Reporter: Ralf Ziller, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060927 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060927 Minefield/3.0a1

If an element is positioned absolutely at the bottom of an element which has min-height set (and position:relative; overflow:hidden), it is positioned at the top of the containing element.
In the latest Release-Version of Firefox the element gets positioned correctly after clicking on a link inside of it (event-handlers of this link don't get fired). The latest nightly build keeps the wrong position.

Reproducible: Always

Steps to Reproduce:
1. see attached file

Actual Results:  
wrong position
jumpy click behavior in Release version

Expected Results:  
correct position
(Reporter)

Comment 1

11 years ago
Created attachment 240322 [details]
document to reproduce the bug
(Reporter)

Updated

11 years ago
Version: unspecified → 1.5.0.x Branch
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: 1.5.0.x Branch → Trunk

Comment 2

11 years ago
> If an element is positioned absolutely at the bottom of an element which has
> min-height set (and position:relative; overflow:hidden), it is positioned at
> the top of the containing element.

I am not sure I understand. Are you saying that being positioned at the top of the containing element is the expected results?

> Actual Results:  
> wrong position

> Expected Results:  
> correct position

Ralf, please, can you clarify, specify what are the actual results and what are the expected results.

Adding testcase and qawanted keywords
Keywords: qawanted, testcase
(Reporter)

Comment 3

11 years ago
Created attachment 240431 [details]
expected result of the test-document

The element is positioned at the bottom
(Reporter)

Comment 4

11 years ago
Created attachment 240432 [details]
actual result

The element is incorrectly positioned at the top

Comment 5

11 years ago
Thank you Ralf for the clarification.

From your testcase, I see that I get actual results with Firefox 2.0 RC1 rv:1.8.1 build 20060918 and with Seamonkey 1.5a rv:1.9a1 build 2006092709
I get expected results with IE 7 RC1, Opera 9.02, Swift 0.1

Component: -> Layout R & A Pos

Now, 

we need to search for possible duplicates, eg if a bug like bug 196937 (or bug 128670) is a duplicate of this one. I believe your bug 354504 is actually just a consequence of bug 128670. I've asked over there to confirm this. That's why I'm leaving qawanted keyword.

If bug 354504 is an independent bug from bug 128670 and independent from bug 196937, then I wonder if your testcase can be furthermore reduced.
Component: Layout → Layout: R & A Pos

Comment 6

11 years ago
Ralf, I believe this bug is a duplicate of bug 128670: summary, description, testcases and comments over there support this. Thererfore, resolving as such.

*** This bug has been marked as a duplicate of 128670 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.