Repeated drag drop of events corrupts end date in month/multiweek view

RESOLVED FIXED

Status

defect
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: cmtalbert, Assigned: cmtalbert)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Lightning 20060927 Thunderbird version 3 alpha 1 (20060927) (Debug Trunk Build)

If you continually drag and drop the same event, the end date will be corrupted in the month/multiweek view. This is due to a fix put into place in order to address draging of recurring appointments in bug 352862. This fix uncovers this new behavior. 

Reproducible: Always

Steps to Reproduce:
1.Create a non-recurring event on the 15th of the month in month/multiweek view
2.Drag and drop event to 21st of month.
3.Drag event back to 15th.

There are several other cases of this that can happen by repeated dragging of the event.

Actual Results:  
The event becomes a multiday event spanning every day from the 21st to the 15th.

Expected Results:  
The event would simply drop back onto the 15th, and the end date would not be corrupted.

This seems to be due to the duration call that is being used in order to try to ensure the new dropped event is the same duration that the event used to be. When the duration is calculated though, part of the event (the end date's NativeTime) is still referring to the date prior to the drag, but the start date refers to the post-drag date.
Flags: blocking0.3+
Posted patch Patch to correct this. (obsolete) — Splinter Review
this solves the problem by following the algorithm used by the week view -- use non item related dates to calcuate the duration and apply that instead of using the item's duration.
Assignee: nobody → cmtalbert
Status: NEW → ASSIGNED
Attachment #240421 - Flags: first-review?(lilmatt)
Posted patch Better patch (obsolete) — Splinter Review
same patch, better diff
Attachment #240421 - Attachment is obsolete: true
Attachment #240422 - Flags: first-review?(lilmatt)
Attachment #240421 - Flags: first-review?(lilmatt)
Posted patch Correct diffSplinter Review
Attachment #240422 - Attachment is obsolete: true
Attachment #240422 - Flags: first-review?(lilmatt)
Attachment #240424 - Flags: first-review?(lilmatt)
Comment on attachment 240424 [details] [diff] [review]
Correct diff

Nice work.
r=lilmatt
Attachment #240424 - Flags: second-review+
Attachment #240424 - Flags: first-review?(lilmatt)
Attachment #240424 - Flags: first-review+
Patch checked in on MOZILLA_1_8_BRANCH, SUNBIRD_0_3_BRANCH, and trunk.

SUNBIRD_0_3_RELEASE tag moved to it.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.