Absolutely slow and ineffective history management

RESOLVED DUPLICATE of bug 223476

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 223476
12 years ago
10 years ago

People

(Reporter: Artem S. Tashkinov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.3) Gecko/20060326 Firefox/1.5.0.3 (Debian-1.5.dfsg+1.5.0.3-2)

1) In current stable Firefox versions it's almost impossible to view your history sorted "by date and site" if you have more than a month history having visited at least 50-100 webpages a day. When you call Ctrl + H and open old entries, scrolling of this history window is almost impossible and consumes 100% of CPU.

2) If you sort such a large history by site and if you try to delete a given site entries accumulated across many days then Firefox will make a hole in your HDD after rewriting the history.dat file great many times.

Reproducible: Always

Comment 1

12 years ago
There's an update of the history code planned for Firefox 3.0 (it was removed from the feature list of Firefox 2.0, because the GUI wasn't ready in time).

http://wiki.mozilla.org/Places
http://wiki.mozilla.org/Browser_History
Dupe of / related to bug 223476?
(Reporter)

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 223476 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 4

11 years ago
Opening history is very slow - takes 20 seconds or more on my system and hanging firefox while it is taking place.  Same for attempting to use the "go" menu.  Firefox 1.5.0.10 and 2.0 on MacOS X 10.4.9 both exhibit the same behaviour. 

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.