Composer does not output correct HTML for special characters

RESOLVED DUPLICATE of bug 195420

Status

RESOLVED DUPLICATE of bug 195420
12 years ago
12 years ago

People

(Reporter: brian.dam.pedersen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; da-dk) AppleWebKit/418.9 (KHTML, like Gecko) Safari/419.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5

When writing special characters, such as e-acute, composer does not emit proper HTML (é). Instead it emits an escaped version of the character, which is unreadable in other browsers, such as Safari

Reproducible: Always

Steps to Reproduce:
1. Open seamonkey composer
2. Create a document with text containing e-acute (e.g. dét)
3. Save file and open it in Safari (or view the source), The proper é is not there.

Actual Results:  
Wrong text is emitted

Expected Results:  
HTML containing é is expected
(Reporter)

Comment 1

12 years ago
Created attachment 240722 [details]
Example text in Composer

Example of edit in composer
(Reporter)

Comment 2

12 years ago
Created attachment 240723 [details]
Result in Safari

Result of example text in Safari

Comment 3

12 years ago
Could you post the source-code that you are getting from SM?  Is it trying to use UTF-8 or something like that?
(Reporter)

Comment 4

12 years ago
Created attachment 240726 [details]
Source code emitted from composer

It looks like it is using UTF-8. The accented character is 2 bytes long. Note that this is not only a problem for e-acute, danish characters (æ ø å) do not emit correctly either (having the same symptoms).

Comment 5

12 years ago
(In reply to comment #4)
> 
> It looks like it is using UTF-8. The accented character is 2 bytes long. Note
> that this is not only a problem for e-acute, danish characters (æ
> ø å) do not emit correctly either (having the same symptoms).

Yes, changing the charset to UTF-8 solves the problem.  So the question is why is Composer outputting UTF-8 characters in the wrong charset (in this case ISO-8859-1) rather than escaping them.  This looks to me similar to bug 195420, so I will dupe to that bug.  Reporter, if you don't agree with me please reopen this bug.


*** This bug has been marked as a duplicate of 195420 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.