Page / Frame of a page escapes the Firefox window

RESOLVED DUPLICATE of bug 263160

Status

()

RESOLVED DUPLICATE of bug 263160
12 years ago
12 years ago

People

(Reporter: spexius, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20060917 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20060917 Firefox/1.5.0.7

Randomly, a full page or a single/multiple frames of a page escape the Firefox window to appear as a standalone window, at least for the fvwm (who assigns it's borders around it/them). The windows act as if they are part of the Firefox window, still (in regard to focusing, closing one of the windows etc.).

As soon as it happened once, this bug seems to persist until restart.

The URL shows one such page having escaped the Firefox window. The remains of Gimp are inside the Firefox window at the place due to the fact it doesn't repaint the screen at this area, leaving garbage there (afterall, it's contents is shown elsewhere).

Reproducible: Sometimes

Steps to Reproduce:
Happens randomly as far as I can tell. Will add more info once I found a way to "force" Firefox doing this.
Actual Results:  
The page/frame "escapes" the Firefox window, gets usual window frames of the fvwm.

Expected Results:  
The page/frame should stay inside the Firefox window.

fvwm 2.5.16, X Window System Version 7, GDK/GTK+ 1.2.10/2.8.19
Happened both on Fedora Core 5 (x86) and Gentoo AMD64, dunno about XWindows+GD/TK versions on Fedora, though
(Reporter)

Comment 1

12 years ago
Fedora Core 5.92 (FC6 Test3), Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060906 Fedora/1.5.0.6-11 Firefox/1.5.0.6 pango-text, GD/TK 2.10.3, fvwm 2.5.16

Problem encountered in FC5 stable, too (no further version information, though).

Comment 2

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7)
> Gecko/20060917 Firefox/1.5.0.7
> Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7)
> Gecko/20060917 Firefox/1.5.0.7
> 
> Randomly, a full page or a single/multiple frames of a page escape the Firefox
> window to appear as a standalone window, at least for the fvwm (who assigns
> it's borders around it/them). The windows act as if they are part of the
> Firefox window, still (in regard to focusing, closing one of the windows etc.).
> 
> As soon as it happened once, this bug seems to persist until restart.
> 
> The URL shows one such page having escaped the Firefox window. The remains of
> Gimp are inside the Firefox window at the place due to the fact it doesn't
> repaint the screen at this area, leaving garbage there (afterall, it's contents
> is shown elsewhere).
> 
> Reproducible: Sometimes
> 
> Steps to Reproduce:
> Happens randomly as far as I can tell. Will add more info once I found a way to
> "force" Firefox doing this.
> Actual Results:  
> The page/frame "escapes" the Firefox window, gets usual window frames of the
> fvwm.
> 
> Expected Results:  
> The page/frame should stay inside the Firefox window.
> 
> fvwm 2.5.16, X Window System Version 7, GDK/GTK+ 1.2.10/2.8.19
> Happened both on Fedora Core 5 (x86) and Gentoo AMD64, dunno about
> XWindows+GD/TK versions on Fedora, though
> 

It happens with my Firefox 1.5.0.2, too. I'm not sure about this but it occurs when I'm using more than 1 window and some tabs for a long browsing time. I'll try to use only one window and might report later.

It's weird because it is random. I can try to open a page now and get the bug, but some reloads can make it reders fine.

If I close one of this pop frame/window the browser crashes, closing all the working windows. I've tried to disable all my extensions but the bug persists.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> It happens with my Firefox 1.5.0.2, too. I'm not sure about this but it occurs
> when I'm using more than 1 window and some tabs for a long browsing time. I'll
> try to use only one window and might report later.
> 
> It's weird because it is random. I can try to open a page now and get the bug,
> but some reloads can make it reders fine.

It hardly happens with full pages, but "inlays" (iframe?, frames, embeds?) are prone to get hit by that bug. Once it started it seems to happen way more often, a restart "fixes" it, though. Furthermore, I have a rather slow gfx card here, which makes Firefox sluggish at times, maybe there are timing issues involved?

> If I close one of this pop frame/window the browser crashes, closing all the
> working windows. I've tried to disable all my extensions but the bug persists.

I don't know if the browser actually crashes; using the fvwm close button on the main window results in an exit of Firefox. I assumed the same happens by clicking on the fvwm close button on one of the silblings.

 ----

Anyway, one more screenie at http://www.mantris.net/firefox/with_fvwm2_bug-2.png.

It shows a wrecked Javadoc page with the frame containing the classes in it's own window. What I found interesting is the location of the tooltips, which were not rendered at the correct position, but relative to the screen origin (I put a copy of the frame there to show it). Missing is the mouse cursor, which is the reason for the "offset" of the shown tooltip to the matching link of the relocated translucent frame.

Comment 4

12 years ago
Created attachment 253987 [details]
a screenshot of this problem

Comment 5

12 years ago
Created attachment 253988 [details]
xwininfo of one of the windows, i have no idea if this is helpful, if not please delete

Comment 6

12 years ago
I just attached a screenshot and xwininfo output. (Sorry about the multiple comments, I'm new to bugzilla).  I've also encountered the same symptoms... it seems to show up after browsing for a long time, multiple windows, many tabs.  Closing one of those made firefox crash, and briefly flashed all sorts of frames (ads mostly) as those detached windows before dying out (I wasn't able to capture that)

I've seen this happen around 3 times now, and it goes away after restarting (even if I recover the same session).

I'm using firefox 2.0.0.1

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263160
You need to log in before you can comment on or make changes to this bug.