"Assertion failure: 0" at jsemit.c:4414

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: jruderman, Assigned: brendan)

Tracking

(Blocks: 1 bug, 4 keywords)

Trunk
PowerPC
Mac OS X
crash, regression, testcase, verified1.8.1
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
js> for each (this in []) { }
Assertion failure: 0, at jsemit.c:4414

This is a recent regression.  It also has bad effects in opt builds.
(Assignee)

Comment 1

12 years ago
Created attachment 240784 [details] [diff] [review]
fix

Sorry about that -- still tired. I need a vacation!

/be
Assignee: general → brendan
Status: NEW → ASSIGNED
Attachment #240784 - Flags: review?(mrbkap)
(Assignee)

Comment 2

12 years ago
I took the liberty of fixing this very recent, very bad regression on the trunk and the 1.8 branch.

/be
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Attachment #240784 - Flags: review?(mrbkap) → review+

Comment 3

12 years ago
Checking in regress-355002.js;
/cvsroot/mozilla/js/tests/js1_5/Regress/regress-355002.js,v  <--  regress-355002.js
initial revision: 1.1
done
Flags: in-testsuite+

Comment 4

12 years ago
I don't know what I or my builds were smoking when I tested this test or checked it in. It should have been in js16 or later since it uses for each and should have caught the syntax error. I would appreciate it if someone would review and make sure it is correct.

Removing js1_5/Regress/regress-355002.js;
/cvsroot/mozilla/js/tests/js1_5/Regress/regress-355002.js,v  <--  regress-355002.js
new revision: delete; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/js/tests/js1_6/Regress/regress-355002.js,v
done
Checking in js1_6/Regress/regress-355002.js;
/cvsroot/mozilla/js/tests/js1_6/Regress/regress-355002.js,v  <--  regress-355002.js
initial revision: 1.1
done

Comment 5

12 years ago
verified fixed 20061003 1.8 windows/mac*/linux 1.9 windows/linux
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1 → verified1.8.1
(Reporter)

Updated

12 years ago
Summary: "Assertion failure: 0, at jsemit.c:4414" → "Assertion failure: 0" at jsemit.c:4414
(Reporter)

Updated

11 years ago
No longer blocks: 349611
(Reporter)

Updated

11 years ago
Blocks: 349611
You need to log in before you can comment on or make changes to this bug.