Closed Bug 355026 Opened 14 years ago Closed 14 years ago

Category menu on Deviant Art no longer works

Categories

(Core :: DOM: Core & HTML, defect)

1.8 Branch
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: stevee, Unassigned)

References

()

Details

(Keywords: fixed1.8.1, regression, testcase)

Attachments

(2 files)

1. New profile, load firefox
2. Go to http://www.deviantart.com/
3. In the upper left corner, there is a 'Category' button. Press the button

Expected:
Menu pops up under the button populated with items that can be clicked.

Actual:
Menu pops up under the button, but is empty.

Works
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/2006093003 BonEcho/2.0

Doesn't Work
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/2006100103 BonEcho/2.0

Checkins
http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=MOZILLA_1_8_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-09-30+02%3A00%3A00&maxdate=2006-10-01+04%3A00%3A00&cvsroot=%2Fcvsroot

Requesting blocking for 2.0 since this is a recent regression.
Flags: blocking-firefox2?
This is a regression from bug 354711 (tested via local backout), I'm working on a minimized testcase.
Blocks: 354711
Attached file minimal testcase
Current trunk passes, current branch fails.
Branch doesn't have bug 342062, which touches a lot of this code, so that may be related.
Commenting out the call to SetDirty() in nsContentList::PopulateSelf "fixes" this bug.
Assignee: nobody → general
Component: General → DOM
Flags: blocking-firefox2?
Product: Firefox → Core
QA Contact: general → ian
Version: 2.0 Branch → 1.8 Branch
Flags: blocking1.8.1?
Keywords: testcase
Flags: blocking1.8.1? → blocking1.8.1+
*** Bug 355021 has been marked as a duplicate of this bug. ***
Severity: normal → major
OS: Windows 2000 → All
Hardware: PC → All
Should I back out bug 354711 from branch?
(In reply to comment #6)
> Should I back out bug 354711 from branch?
> 

Yep - let's do that until we can figure out a better solution.  Backing us out at least gets us in sync with 1.5.0.7...
backed out bug 354711 from 1.8.1.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Attached file MochiKit unit test
This is Gavin's testcase converted into the MochiKit testcase format.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.