Closed Bug 355057 Opened 15 years ago Closed 15 years ago

enable opening javascript-links in new page

Categories

(Core :: DOM: HTML Parser, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 55696

People

(Reporter: sebastian.moser, Assigned: mrbkap)

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060927 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060927 Firefox/1.5.0.1

On many AJAX-sites, there are links have no URL, but a JavaScript-action (JavaScript:XXX()). This links can't be opened in a new tab/window.

I will create a testcase to show the problem

Reproducible: Always

Steps to Reproduce:
1. Go to the test-case that I will upload shortly.
2. press CTRL and click on the link "Show contents"
Actual Results:  
I see a new, empty tab.

Expected Results:  
I want to see the page with the javascript-action loaded

Load the page that was loaded *before* clicking on the link and execute the JavaScript-function there. This would simulate the behavior and would make using AJAX-applications much easier.

Normal people don't care if there is a new page loading, or just an AJAX-application that loads data in the background and processes it. This would remove a unnecessary difference between AJAX- and non-AJAX-webpages.
Keywords: testcase
Dupe of bug 55696?
Indeed.

*** This bug has been marked as a duplicate of 55696 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.