prettify about:config warning

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
General
--
enhancement
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: philippe (part-time), Assigned: philippe (part-time))

Tracking

({fixed1.8.1.1})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8.1.1

Details

Attachments

(5 attachments, 2 obsolete attachments)

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a1) Gecko/20061002 Camino/1.2+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a1) Gecko/20061002 Camino/1.2+

Give the 'about:config' scary warning page some Camino branding.
per bug 303193 comment #33.

Reproducible: Always
(Assignee)

Comment 1

11 years ago
Created attachment 240872 [details]
screenshot of proposal
(Assignee)

Comment 2

11 years ago
If you prefer the 'Scary Warning Title' to be coloured blue (similar to the colours in bug 303193), that is trivial to change.

I'm not sure what I've done is the 'correct' or 'best' way to handle this. Someone with more knowledge of XUL should correct me. I'll attach the modified config.css file next.
(Assignee)

Comment 3

11 years ago
Created attachment 240873 [details]
modified config.css

changes:
#exclam
{
  list-style-image: none; /* <-- set to none */
  margin-right: 3em;
  background: /* attached as data URI */
  width: 109px;
  height: 108px; /* matching size of image */
}
Confirming this ;)

I think we probably want to sync with the styles from bug 303193 as closely as possible (now that those styles are final), unless someone offers a compelling reason to the contrary.
Target Milestone: --- → Camino1.1
Ahem.  Clicking the right button first ;)  What was it Hicks said?  Shuffles feet and whistles?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 6

11 years ago
Created attachment 241286 [details]
screenshot, proposal 2

The 'Be Careful !' title in blue, better balancing the white-space around the alert icon.
(Assignee)

Comment 7

11 years ago
Created attachment 241287 [details]
screenshot, proposal 2

Ahem, correct mime-type... 
a disease :=)
Attachment #241286 - Attachment is obsolete: true
(Assignee)

Comment 8

11 years ago
Created attachment 241288 [details]
screenshot, proposal 3

Larger type for the 'Be Careful !' warning message, some more white-space around that title.
(Assignee)

Comment 9

11 years ago
While playing around with the Camino-alert icon image, taken form bug , I notice that the image has some 10px white, empty space to the left. For the purpose of testing I cropped it out, but that results in some slight degradation of the image, due to recompression.

Jon, can you attach the image in png format, without that empty space ? It should be about 100px wide.

Comment 10

11 years ago
Created attachment 241304 [details]
Cropped Error Icon

Here we are. The extra whitespace was just me being lazy and not putting it into the CSS!
philippe, can you attach a modified config.css that does "proposal 3" (and includes the icon as data: of course)?
Assignee: nobody → phiw
(Assignee)

Comment 12

11 years ago
Created attachment 242021 [details]
modified config.css based on proposal 3

finetuned some white-space (a pixel here, a pixel there), with Jon's image.
Attachment #240873 - Attachment is obsolete: true
Comment on attachment 242021 [details]
modified config.css based on proposal 3

Whoever checks this in (as embed-replacements/skin/classic/global/config.css) should probably add philippe to the contributor list in the file's license section.
Attachment #242021 - Flags: superreview?(mikepinkerton)
Attachment #242021 - Flags: review+
Comment on attachment 242021 [details]
modified config.css based on proposal 3

rs=pink
Attachment #242021 - Flags: superreview?(mikepinkerton) → superreview+

Comment 15

11 years ago
Checked in on 1.8branch and trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Updated

11 years ago
Keywords: fixed1.8.1.1

Updated

11 years ago
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.