Firefox crashes when typing into a form on a page that hasn't yet been fully loaded [@ nsTextInputListener::EditAction]

RESOLVED WONTFIX

Status

()

Core
Layout: Form Controls
--
critical
RESOLVED WONTFIX
12 years ago
7 years ago

People

(Reporter: Ivan, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs stack evaluated for usefulness - editor/events/forms][testday-20110902], crash signature, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

When you make a new forum thread and start typing right away without waiting for the page to be fully loaded, Firefox sometimes crashes, and sometimes fills the forms with empty spaces instead of letters you are typing.

The forum I encountered this on might be unavailable for unregistered users, and registration is closed, but it uses a quite common UBBThreads script plus a bunch of customizations.

Reproducible: Sometimes

Steps to Reproduce:
1. Navigate to a 'start new thread' page using a slow internet connection
2. Start typing when the form appears without waiting for the page to load fully

Actual Results:  
Browser sometimes crashes and sometimes typing results in blank chars instead of letters

Expected Results:  
Forms should always be filled ok while the page is still being loaded

Comment 1

12 years ago
Could you install or enable Talkback and get an incident ID for the crash? http://kb.mozillazine.org/Talkback
(Reporter)

Comment 2

12 years ago
Talkback incident ID is TB24064269M

Comment 3

12 years ago
There are a few bugs with this stack signature, but the stacks aren't exactly the same.

Ivan, can you download Firefox 2 RC2 and see if this bug still occurs with it?

Incident ID: 24064269
Stack Signature	nsTextInputListener::EditAction 2c3b0ce9
Product ID	Firefox15
Build ID	2006090918
Trigger Time	2006-10-03 01:04:47.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (0013874d)
URL visited	forum.b.gz.ru/newpost.php
User Comments	Started typing into form that hasn't yet been fully loaded
Since Last Crash	1205 sec
Total Uptime	1205 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8.0-Release/WINNT_5.2_Depend/mozilla/layout/forms/nsTextControlFrame.cpp, line 455
Stack Trace 	
nsTextInputListener::EditAction  [mozilla/layout/forms/nsTextControlFrame.cpp, line 455]
nsEditor::NotifyEditorObservers  [mozilla/editor/libeditor/base/nsEditor.cpp, line 1794]
nsAutoPlaceHolderBatch::~nsAutoPlaceHolderBatch  [mozilla/editor/libeditor/base\nsEditorUtils.h, line 66]
nsPlaintextEditor::HandleKeyPress  [mozilla/editor/libeditor/text/nsPlaintextEditor.cpp, line 381]
nsTextEditorKeyListener::KeyPress  [mozilla/editor/libeditor/text/nsEditorEventListeners.cpp, line 250]
DispatchToInterface  [mozilla/content/events/src/nsEventListenerManager.cpp, line 141]
nsEventListenerManager::HandleEvent  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1781]
nsGenericElement::HandleDOMEvent  [mozilla/content/base/src/nsGenericElement.cpp, line 2193]
nsHTMLInputElement::HandleDOMEvent  [mozilla/content/html/content/src/nsHTMLInputElement.cpp, line 1478]
PresShell::HandleEventInternal  [mozilla/layout/base/nsPresShell.cpp, line 6476]
PresShell::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6259]
nsViewManager::HandleEvent  [mozilla/view/src/nsViewManager.cpp, line 2514]
nsViewManager::DispatchEvent  [mozilla/view/src/nsViewManager.cpp, line 2246]
HandleEvent  [mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1258]
nsWindow::DispatchKeyEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 3454]
nsWindow::OnChar  [mozilla/widget/src/windows/nsWindow.cpp, line 3709]
nsWindow::OnKeyDown  [mozilla/widget/src/windows/nsWindow.cpp, line 3547]
nsWindow::ProcessMessage  [mozilla/widget/src/windows/nsWindow.cpp, line 4538]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1440]
USER32.dll + 0x3a68 (0x77d43a68)
USER32.dll + 0x3b37 (0x77d43b37)
USER32.dll + 0x3d91 (0x77d43d91)
USER32.dll + 0x3df7 (0x77d43df7)
nsAppStartup::Run  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
main  [mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x214c7 (0x77e814c7)
Component: General → Layout: Form Controls
Keywords: crash, qawanted
Product: Firefox → Core
QA Contact: general → layout.form-controls
Summary: Firefox crashes when typing into a form on a page that hasn't yet been fully loaded → Firefox crashes when typing into a form on a page that hasn't yet been fully loaded [@ nsTextInputListener::EditAction]
Version: unspecified → 1.8 Branch
(Reporter)

Comment 4

12 years ago
Are you sure 2.0 RC2 is already out? I've downloaded RC1 and will try to reproduce bug using it later today or tomorrow morning. If you have a link to official Firefox 2.0 RC2 windows package, please share.

Comment 5

12 years ago
Sorry, I was getting ahead of myself. You're right, RC1 is the latest version.
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> Sorry, I was getting ahead of myself. You're right, RC1 is the latest version.
> 

Well, while I was busy with my work last week, RC2 was actually released. I've just tried it, and was able to reproduce the bug, although failed to notice incident ID when it reported the crash

Comment 7

11 years ago
I too have this issue, but its not during a forum post before the page loads. Randomly I will go to post a response and at first I can type, but can not arrow up or down. Then I will hit enter to go down a line and Firefox crashes. I'm using firefox 2.0.0.3, windows XP sp2 and standard install of Firefox (no theme's, fancy modules or plugins).  

Comment 8

11 years ago
Firefox just crashed on my computer with 

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070509 Firefox/2.0.0.4 ID:2007050903

while typing text into a dropdown-box.

TB32630940Y  

Updated

11 years ago
Depends on: 339975
Smaug, can you tell what went wrong from looking at the stack?
Whiteboard: [needs stack evaluated for usefulness - editor/events/forms]

Comment 10

8 years ago
Jim, Ivan do you still see this?
Severity: normal → critical
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsTextInputListener::EditAction]
http://bit.ly/oHLTDe

I'm seeing 11 instances of this crash in the last month. However, all of them are on 4.0 Beta builds and only on Mac.

Since this is over a year old I'm going to say this is likely not an issue anymore. Resolving WONTFIX -- please reopen if you can justify fixing it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → WONTFIX
Whiteboard: [needs stack evaluated for usefulness - editor/events/forms] → [needs stack evaluated for usefulness - editor/events/forms][testday-20110902]
You need to log in before you can comment on or make changes to this bug.