webclient core dumps on Solaris when I select File--New Window

ASSIGNED
Assigned to

Status

P3
normal
ASSIGNED
19 years ago
7 years ago

People

(Reporter: geetha.vaidyanaathan, Assigned: ashuk)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Hi ,

  Have a most recent build of webclient running with Mozilla M13.
  Testing webclient on Solaris.
  When I do a File --- new window, webclient aborts.
 This is the error msg from the cmd window..
 
constructed with binDir: /opt/mozilla/java/webclient/src_moz/../../../dist/bin
url: http://yahoo.com
in BrowserControlCanvas setBounds: x = 0 y = 0 w = 640 h = 480
debug: edburns: native library does implement webclient.WindowControl
Can't setBounds(java.awt.Rectangle[x=0,y=0,width=639,height=479]) null

Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 1410 error_code 3 request_code 8 minor_code 0

aborting...
SIGABRT   6*   abort (generated by abort(3) routine)
    si_signo [6]: SIGABRT   6*   abort (generated by abort(3) routine)
    si_errno [0]: Error 0
    si_code [-1]: SI_LWP [pid: 15520, uid: 35239]
	stackpointer=fe704234

Thanks
Geetha
(Reporter)

Updated

19 years ago
Summary: webclient core dumps on Soalris when I select File--New Window → webclient core dumps on Soalris when I select File--New Window

Comment 1

19 years ago
Can you please take a break from your recent round of implementation tasks and
look at this bug.  Please post a reason for the crash here and see if the fix is
easy.

Assignee: edburns → ashuk
geetha.vaidyanaathan@sun.com - are you still seeing this problem with recent 
builds of Mozilla?

Gerv
(Reporter)

Comment 3

19 years ago
I have tested with M13 build of mozilla and M3 build of webclient on Solaris.
The bug deosnot exist any more

-geetha
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

19 years ago
oops.. I made a mistake in verifying this as fixed. Bug still exists with M13
build of mozilla with M3 webclient . However once webclient integration
with M15 is in place , this bug should be fixed.

geetha
Reopening meantime.

Gerv
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

19 years ago
confirming for now.  geetha.vaidyanaathan please report back on this one.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 7

18 years ago
So is this fixed?
Summary: webclient core dumps on Soalris when I select File--New Window → webclient core dumps on Solaris when I select File--New Window
(Assignee)

Comment 8

18 years ago
Not yet. Has to do with GTK and interaction with Java native peer windows
on solaris that use the motif toolkit.
(Assignee)

Comment 9

18 years ago
Core dump problems resolved. After RTM sync up, File->New Window was not working
on any platform. 44327 addresses that problem. Once 44327 is fixed, this bug may
require some more additions in the code for the solaris case (gtk event loop
issues not seen on Windows)

_Ashu
Depends on: 44327

Comment 10

18 years ago
Changing QA contact
QA Contact: geetha.vaidyanaathan → avm

Comment 11

18 years ago
I cannot reproduce this bug with nightly mozilla & webclient on Solaris 2.8
But "EmbeddingMozilla#2" window do not render any pages. If i enter a new url 
and press enter button, webclient shown on status string that page loaded, but 
it isn't render this page on screen.
Ashu, plese verify is it reproduced for you.

Comment 12

18 years ago
Add me to cc list

Comment 13

17 years ago
Platform: x86 and sparc Solaris 2.8.
Mozilla: Netscape61_RELEASE branch + JAVADEV_6_1_20010831 blackwood branch.
New window doesn't render any pages and hangs webclient.
I confirm it.
Component: Java APIs to WebShell → Java APIs to WebShell
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.