Escape key does not close find toolbar when "Match case" has focus

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Toolkit
Find Toolbar
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: John Hansen, Assigned: mano)

Tracking

1.8 Branch
mozilla1.9alpha1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061001 BonEcho/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061001 BonEcho/2.0

The escape key will not close the find toolbar if the "Match case" checkbox has the focus. Find-as-you-type is affected as well.

Reproducible: Always

Steps to Reproduce:
1. Ctrl+F or start typing with FAYT enabled.
2. Tab to, or click the "Match case" checkbox.
3. With the dotted border surrounding "Match case", press Escape

Actual Results:  
The find toolbar does not close unless the "Match case" is blurred.

Expected Results:  
It should close regardless of focus location on the toolbar.
(Reporter)

Comment 1

12 years ago
Actually, the escape key will not close the find toolbar if the focus is on anything else in the chrome or content.

I wasn't sure whether this was intended when I filed the bug.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061002 Minefield/3.0a1
Escape key works, when the focus is in the input field. When I first type the search term and then put the check mark in the Match case box, the esc key does nothing.
This is not a regression; even 1.0.7 shows this behavour.
Confirming, as I can't find an obvious dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

12 years ago
The keypress handler is only attached to the textbox: http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/components/typeaheadfind/content/findBar.inc&rev=1.13&mark=8#1.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 2.0 Branch
Assignee: nobody → mano
Depends on: 288254
Fixed in bug 288254.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 alpha1
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.