CPU usage at 100% after laptop wakes back up from sleep

RESOLVED DUPLICATE of bug 213637

Status

()

defect
RESOLVED DUPLICATE of bug 213637
13 years ago
13 years ago

People

(Reporter: aroetter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

About 50% of the time, when I wake my laptop (IBM T43p) from a sleep, firefox is using 100% of the CPU.

I have to kill it and restart for this to go away. I generally have 3-10 tabs open, but haven't found any magic tabs that always cause this. i almost always have gmail open, but have yet to do an experiment to see if that is the culprit. i also have the google toolbar installed, if that matters.

Reproducible: Sometimes

Steps to Reproduce:
1. Use firefox, browsing normall, have several tabs open, etc
2. Put laptop to sleep
3. Wakeup.

Actual Results:  
firefox.exe will be using 100% CPU

Expected Results:  
firefox.exe shouldn't consume all the CPU

i *believe* this is more likely to happen if the computer has been to sleep for longer, but im not sure if that is true.
*** Bug 360335 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
Here's some more info:

I was googling for a remedy for this annoying bug, and eventually found a discussion about something that seemed similar. Someone said that some IBM laptops get wrong version (a version suited only for newer computer models) of wireless networking driver from Windows Update, and recommended us to rollback to an earlier installed driver or to install the correct one manually. I decided to run IBM's System Update tool and - yes - another driver was then installed.

My plan was then of course to continue running everything as normal, with the same 20 tabs open in Firefox, and see if the problems went away - but unfortunately Firefox' Session Manager add-on had some problems once and refused to load any tabs, so due to this I was running Firefox for 3 days with just a handful of tabs. 
*** During this time, the 100% CPU usage problem was never shown! ***

Of course I hoped that the corrected wireless networking driver was the reason for everything working alright again, but yesterday I opened some more tabs (some of which are the same as during the earlier problematic period) and today, after waking up the laptop, 
*** the 100% CPU usage problem is here again. :-( ***
The only difference that I can see when comparing to the last month's problems is that the wireless network was today working from the start (perhaps thanks to the corrected driver?), and stopped functioning right AFTER I choosed to kill the Firefox process. (Earlier, the woken-up laptop used to have a non-functional wireless network while Firefox was eating 100% CPU, saying "limited connectivity", and I would often have to Repair the connection after killing Firefox to have it running normally again.)

The strangest detail, as I see it, is that the problem only seems to appear after the computer has been in Hibernation or Standby FOR HOURS. But if I have it in Hibernation/Standby for half an hour of so, it wakes up just fine. 
What could be behaving differently in these cases? Firefox? Windows? The computer itself? The networking driver? My D-link DI-624 WLAN router?

I never expected the tabs/webpages in themselves to be the cause of the problem, since I'm used to having lots of them opened, but anyway I thought I would mention which pages I had opened today when the Firefox process was having its problems:

http://mail.google.com/mail/
http://www.freesample.canon-europe.com/
http://help.eclipse.org/help30/index.jsp?topic=/org.eclipse.platform.doc.isv/reference/api/org/eclipse/swt/graphics/Color.html
http://giss.tv/
http://www.vagueterrain.net/content/archives/journal03/journal03.html
http://www.cf.se/CFWeb/valkommen/stipendier/
http://www.bspmedia.eu/losningar3d.shtml
http://www.3dmsi.net/billboard2.html
http://www.freeantennas.com/projects/template/index.html
http://www.fridatebus.com/
http://99musik.se/forum/showthread.php?p=305495#post305495
http://tone.mymusic.dk/biografi/
http://en.wikipedia.org/wiki/Backpropagation
http://galaxy.agh.edu.pl/~vlsi/AI/backp_t_en/backprop.html
http://www.we-make-money-not-art.com/archives/009105.php
http://www.tii.se/reform/projects/pps/soniccity/index.html
http://www.viktoria.se/fal/events/mobilemusic/
http://www.futuresonic.com/
http://www.timebend.net/projects/?projectID=tap_and_bass&noframes=1
http://loopia.se/domannamn/sokdoman/?action=submit&domain=sync24&Submit2=S%F6k
http://www.eclipse.org/search/search.cgi?q=swt+button+setbackground&cmd=Search%21&form=extended&wf=574a74&ps=50&m=all&t=5&ul=&wm=wrd&t=News&t=Mail

Moreover, I'm running 
an IBM T41 laptop, Intel Pentium M 1600MHz + 768 MB RAM, 
with Windows XP Professional version 2002 + SP2, 
Firefox 1.5.0.8 with add-ons:
Session Manager 0.4.3
Web Developer 1.0.2
DOM Inspector 1.8.0.8
Disable Targets For Downloads 1.0.1
DownThemAll! 0.9.9.7

PLEASE let me know if I can try out some other version or setting to help understanding this problem.

Having to wait for the slow startup while Firefox is eating 100% CPU and trying to kill the process and repairing the network connection and restarting Firefox with the correct set of tabs from the Session Manager add-on and trying to not go completely nuts, at least once a day (more often if I have to put the computer to sleep during daytime), is becoming a real pain. And considering the alternatives, the new MSIE 7 with tab support and all, there IS an easy way out of the problem for us who have it. And how many are we? I have no idea. Personally I changed to Firefox two years ago since it was a nice way of avoiding Microsoft AND because Firefox was more handy. Now it's not more handy anymore, but I think I will stick to it for some weeks more and see... but beware: far from all Firefox users are that religious.

Please contact me if I can be of any help.
Mattias Rickardsson, Sweden
mr (a) analogue.org
*** Bug 364767 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 366876
Are there people here who have also this problem if the latest flash player is installed?

Comment 6

13 years ago
Yes, I think so - three days ago I was visiting
http://www.vanessabeecroft.com/
and it forced me to install a new flash player version, which I guess is the latest one. (How can I see what flash player version is installed?)
After this, when I still had the vanessabeecroft site open in one of my Firefox windows, the 100% CPU problem was present both times I woke up my laptop from sleep. After that, I got annoyed and closed some Firefox tabs/windows, including the vanessabeecroft one, and the problem was gone next time I woke it up.

Comment 7

13 years ago
Mattias, to check the version of your flash player (or any other plugin, for that matter) type about:plugins in the address bar. 

Comment 8

13 years ago
Thank you, Pavel.
Firefox says:

Shockwave Flash
    File name: npswf32.dll
    Shockwave Flash 9.0 r28

Comment 9

13 years ago
(In reply to comment #8)
That version is ok, 9.0 r7 and higher should be save. See bug 265172.

(In reply to comment #2)
> The strangest detail, as I see it, is that the problem only seems to appear
> after the computer has been in Hibernation or Standby FOR HOURS. But if I have
> it in Hibernation/Standby for half an hour of so, it wakes up just fine. 
See Bug 327050/Bug 213637. After >>1h your network has dropped the connection. Duping to the general one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 213637
You need to log in before you can comment on or make changes to this bug.