Closed Bug 355360 Opened 13 years ago Closed 13 years ago

#unifinder-search-results-listbox min-height property is too small

Categories

(Calendar :: Sunbird Only, defect, trivial)

x86
Windows XP
defect
Not set
trivial

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ogirtd, Assigned: sipaq)

References

Details

Attachments

(5 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: 

In order to avoid a cosmetic bug - #unifinder-search-results-listbox should have a min-height, So that the scrollbars wouldn't show on top of the tree.

Reproducible: Always
Attached image example
*** Bug 355359 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Component: Calendar Views → Sunbird Only
Ever confirmed: true
QA Contact: views → sunbird
There already is a min-height set, but you are right: the value of "40" is still too small.
I recently added Unifinder into Lightning and changed the min-height as well.

Just go to into "classic.jar" and change the file "calendar.css" to increase the value to 58 which worked for me in Windows platform (If you have enough time, you could also create a patch and ask for ui-review...):


/*--------------------------------------------------------------------
 * Unifinder
 *-------------------------------------------------------------------*/
/* workaround to avoid Window Flick */
#unifinder-search-results-listbox
{
   /* SG, 20.02.2007 - increased to display scrollbar and at least 2 lines */
   min-height : 58px ;
}
-> Morphing bug and assigning it to me
Status: NEW → ASSIGNED
Summary: tree #unifinder-search-results-listbox should have min-height property → #unifinder-search-results-listbox min-height property is too small
Assignee: nobody → bugzilla
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Attached patch Patch v1Splinter Review
Patch to show at least 3 lines in the unifinder. I will attach a screenshot for UI review. Matthew, can you please check, whether this looks ok on OS X, since I can only test this on Windows XP.
Attachment #258957 - Flags: ui-review?(mvl)
Attachment #258957 - Flags: first-review?(lilmatt)
Comment on attachment 259474 [details]
Mac screenshot with patch

This is as small as it you can make the unifinder before it collapses on Mac, using this patch.
Comment on attachment 258957 [details] [diff] [review]
Patch v1

You want to show 4 lines on Mac, since otherwise the scrollbar is drawn goofy.
92px is a good value IMHO.  I'll attach a screenshot of that.  r=lilmatt with that fixed.
Attachment #258957 - Flags: first-review?(lilmatt) → first-review+
Comment on attachment 258957 [details] [diff] [review]
Patch v1

ui-review=mvl with the 4 lines as proposed by matt.
Attachment #258957 - Flags: ui-review?(mvl) → ui-review+
Patch with the Mac change checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070325 Calendar/0.5pre
VERIFIED per comment#13
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.