cmd-up takes you up a path of the URL instead of to top of page

RESOLVED FIXED

Status

SeaMonkey
UI Design
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Not interested in Mozilla any more, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey1.1.1, regression})

Trunk
PowerPC
Mac OS X
fixed-seamonkey1.1.1, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.49 KB, patch
Samuel Sidler (old account; do not CC)
: review+
Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
: review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060821 SeaMonkey/1.1a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060821 SeaMonkey/1.1a

Pressing command-up arrow causes webpage to be with a different page from the same site. Previously it took you to the top of the current page. Command-down arrow still takes you to the bottom of the current page. The existing behavior is an absolute must for laptop users who do not have 'home' and 'end' keys.

Reproducible: Always

Steps to Reproduce:
1. Go to a page
2. Press command-up arrow


Actual Results:  
Page is replaces, usually with the main page for that site.

Expected Results:  
Page should remain and you should be taken to the top of the page.
I can confirm this behavior, but am changing the summary a bit.

In SeaMonkey 1.0.x, pressing cmd-up would take you to the top of the page, if you had scrolled it.

In SeaMonkey 1.1 and trunk, pressing cmd-up takes you up a directory in the path. For example, if you were at http://localhost/testing/123/, cmd-up would take you to http://localhost/testing/.

This appears to be a regression, but I'm sure it's actually the casualty of a new feature. Unfortunately, I can't find the bug that added this behavior. As such, I'm not confirming it because there may have been discussion already.
Keywords: regression
Summary: Command-up arrow causes webpage to be replaced. Should take you to top of page. → cmd-up take you up a path of the URL instead of to top of page
(Assignee)

Comment 2

11 years ago
Sorry, when I fixed bug 33684 I didn't realise Cmd+Up was already in use.

What key would you like it to be, if any? (You can choose any key you like because it goes in platformNavigationBindings.xul).
Assignee: nobody → neil
Blocks: 33684
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

11 years ago
(Cmd+Up also moves tab left)

How about Cmd+Shift+Up ? I don't think it's used anywhere.

Comment 4

11 years ago
Hmm, maybe Alt+Up works as well.
Technically, cmd-shift-up used to for selecting "from here to the top the of page". Alt/option- or ctrl- up seem reasonable though.

alt/option-up go to the top of textareas though, so as long as it doesn't interfere with that (which it shouldn't because focus is different), then it should be good.
(Assignee)

Comment 6

11 years ago
It's actually alt-up on the other platforms, but I changed it to cmd-up to match the back and forward keys... are we agreed on alt-up?

Comment 7

11 years ago
(In reply to comment #6)
> It's actually alt-up on the other platforms, but I changed it to cmd-up to
> match the back and forward keys... are we agreed on alt-up?
> 

Alt+Up sounds good to me. If you bother to update Help on trunk (otherwise I can), Alt is Opt on mac ;-)
(Assignee)

Comment 8

11 years ago
Created attachment 254462 [details] [diff] [review]
Proposed patch
Attachment #254462 - Flags: review?(samuel.sidler)
Attachment #254462 - Flags: review?(cst)
Comment on attachment 254462 [details] [diff] [review]
Proposed patch

I don't build SeaMonkey, but this change looks good to me.

r=me
Attachment #254462 - Flags: review?(samuel.sidler) → review+
Attachment #254462 - Flags: review?(cst) → review+
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
Component: Keyboard: Navigation → XP Apps: GUI Features
Product: Core → Mozilla Application Suite
(Assignee)

Updated

11 years ago
Attachment #254462 - Flags: approval-seamonkey1.1.1?
(Assignee)

Comment 10

11 years ago
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Summary: cmd-up take you up a path of the URL instead of to top of page → cmd-up takes you up a path of the URL instead of to top of page

Comment 11

11 years ago
Comment on attachment 254462 [details] [diff] [review]
Proposed patch

a=me for SM1.1.1 (one more needed)
(Assignee)

Comment 12

11 years ago
(In reply to comment #11)
>(From update of attachment 254462 [details] [diff] [review])
>a=me for SM1.1.1 (one more needed)
I don't think it is, so I've checked it in to the branch.
Keywords: fixed-seamonkey1.1.1

Comment 13

11 years ago
Comment on attachment 254462 [details] [diff] [review]
Proposed patch

a+ per correct notion on Comment #12
Attachment #254462 - Flags: approval-seamonkey1.1.1? → approval-seamonkey1.1.1+

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.