z-index with negative value is out of flow

RESOLVED DUPLICATE of bug 78087

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 78087
12 years ago
12 years ago

People

(Reporter: Alexander, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Just try next code.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 //EN">   
<html>   
<head>   
<title>z-index with negative value</title>
<style type="text/css">   
html
{
	background-color: #ccc;
}
body{   
	margin: 30px;   
	background-color: #f5f5f5 !important;
	border: 1px solid #999;
}   
#image{   
  border: 1px solid #c00 ;   
}
</style>   
       
</head>   
<body>   
Test
<div style="position: absolute; z-index: -1; top: 0px; left: 0px; width: 100px; height: 100px; background-color: #999;"></div>
</body>   
</html>

Reproducible: Always

Actual Results:  
Gray box shoul be placed under BODY tag

Expected Results:  
Gray box is out of flow

*** This bug has been marked as a duplicate of 78087 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.