Last Comment Bug 355480 - Round-trip change for "const arguments;"
: Round-trip change for "const arguments;"
Status: RESOLVED FIXED
: testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- minor (vote)
: ---
Assigned To: general
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 740259
Blocks: jsfunfuzz
  Show dependency treegraph
 
Reported: 2006-10-04 21:34 PDT by Jesse Ruderman
Modified: 2012-04-11 19:37 PDT (History)
5 users (show)
jruderman: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jesse Ruderman 2006-10-04 21:34:15 PDT
js> f = function() { const arguments; }
function () {
    arguments;
}
js> eval("" + f)
function () {
}
Comment 1 Jesse Ruderman 2007-04-24 17:52:01 PDT
js> function() { const arguments, []=y }  
function () {
    arguments, const [] = y;
}

That really doesn't work :)
Comment 2 Luke Wagner [:luke] 2012-04-11 12:12:22 PDT
Fixed by making 'arguments' a real local binding.

*** This bug has been marked as a duplicate of bug 740259 ***

Note You need to log in before you can comment on or make changes to this bug.