Privacy option to allow cookies "for the originating web site only" is missing

RESOLVED DUPLICATE of bug 349680

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 349680
12 years ago
12 years ago

People

(Reporter: Simon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0

This option gave you at least a little privacy and protection against large scale advertisers tracking your every single step on sites they got their fingers on without the need to micromanage the whole cookies thing.
Can't think of a reason why it would be dropped intentionally, imho it should even be active by default.

Reproducible: Always

*** This bug has been marked as a duplicate of 349680 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 2

12 years ago
I'm guessing they removed the option because mozilla.org is in cahoots with the CIA--- to *SPY* on the browsing habits of Firefox users, and track the data at a site such as "Carl-Rove.com".

:(((

Seriously, I *DO* understand the problem with Frames, (and half-understand the problem with redirects), but we should provide the functionality: and provide it WITH a very fast allow/disallow "button" for those who want to disable 3rd party cookies generally, but need to temporarily enable it to "see" a page which doesn't display sufficiently well unless "foreign" frame-based Cookies, or redirects, are allowed.

In those particular cases, the privacy-minded FF user would see that the page is too messed up to work with, press the button to "enable", do his/her stuff, then press the button again to "disable". (A button similar to the "quickjava" extension's buttons for Java and JavaScript.) 

Maybe it'll be IE-7 for those of us who want to protect our privacy? I see that Konqueror provides a similar checkbox in 'Configure Konqueror --> 'Cookies' --> 'Policy' ("Only accept cookies from the originating server). But I bet that it has the same issue we've had, accepting foreign cookies in "foreign" frames and redirects of the page. I wonder what Opera does?
You need to log in before you can comment on or make changes to this bug.