Closed Bug 355620 Opened 13 years ago Closed 8 years ago

Lines enclosed in <simplelist> do not wrap in the PDF version of the Bugzilla Guide

Categories

(Bugzilla :: Documentation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 3.6

People

(Reporter: hayden, Assigned: chtrom)

References

()

Details

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-4.1
Build Identifier: Bugzilla 2.22

The Bugzilla Guide - 2.22 Release
Chapter 6. Using Bugzilla
Section 6.6. Bug Lists
In the PDF document page margins are ingnored for the following items in the list:
RSS, Change several bugs at once, Edit Search, Remember Search As

Documentation runs off edge of page and can not be read.

Reproducible: Always

Steps to Reproduce:
1. Bring up the PDF version of the Bugzilla Guide (URL above)
2. Jump to section 6.6. (actual page 79 of document, numbered as page 71)
3. Look at list of features, several run past right margin and off the page.



Expected Results:  
Line wrap so all words can be read and page margins are honored.
This section is now 5.5.3 on tip, see http://www.bugzilla.org/docs/tip/html/query.html#list. I can indeed see the problem on tip in the PDF version of the doc. Colin, any idea?
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Summary: Sect 6.6 of the Bugzilla Guide fails to line wrap correctly in PDF version → Sect 5.5.3 of the Bugzilla Guide fails to line wrap correctly in PDF version
This affects all places where we use <simplelist> </simplelist>.
Summary: Sect 5.5.3 of the Bugzilla Guide fails to line wrap correctly in PDF version → Lines enclosed in <simplelist> do not wrap in the PDF version of the Bugzilla Guide
Attached patch WIP, v0.1 (obsolete) — Splinter Review
If someone wants to fix this bug himself, here is how to do it: <simplelist> should be replaced by <variablelist>.
Whiteboard: [Good Intro Bug]
Target Milestone: --- → Bugzilla 5.0
Attached patch Patch.V2 (obsolete) — Splinter Review
Attachment #585303 - Flags: review?
In Patch.V2 I changed every <simplelist> to a <variablelist> where the text did not remain contained within the margins of the page when converted to PDF.
Comment on attachment 585303 [details] [diff] [review]
Patch.V2

>=== modified file 'docs/en/xml/administration.xml'
>+                 <varlistentry>
>+                   <listitem>
>+                     Bug ID: A field where you can enter the ID of another bug from

Each element must be enclosed in <term></term>, see the example I attached to the bug. See also http://docbook.org/tdg/en/html/varlistentry.html
Attachment #585303 - Flags: review? → review-
Attached patch Patch.V3 (obsolete) — Splinter Review
Updated patch to address the issue described in comment 6.
Attachment #585303 - Attachment is obsolete: true
Attachment #631652 - Attachment description: Updated patch → Patch.V3
Attachment #631652 - Flags: review?(LpSolit)
Comment on attachment 631652 [details] [diff] [review]
Patch.V3

>=== modified file 'docs/en/xml/administration.xml'

>+	<variablelist>
>+               <varlistentry>
>+                 <term>Bug ID:</term>
>+		   <listitem>
>+		   A field where you can enter the ID of another bug from

The indentation is very wrong, probably because you used tabs for the indentation. Please replace tabs by whitespaces and make sure the indentation is 2 whitespaces per level. Also, compiling the documentation fails because the text in <listitem> must be enclosed in <para></para> first, which I forgot to include in my WIP. So the few lines above should look like this:

    several types available:
    <variablelist>
      <varlistentry>
        <term>Bug ID:</term>
        <listitem>
          <para>
            A field where you can enter the ID of another bug from ...
          </para>
        </listitem>
      </varlistentry>

      <varlistentry>
        etc...

Also, leaving an empty line between each <varlistentry> </varlistentry> block as shown above improves readability a lot. It would be great if you could include this in your next patch.


Anyway, thanks for your contribution so far. I know that's not the most exciting piece of code to write. But I guess the next shoot should be the good one. :)
Attachment #631652 - Flags: review?(LpSolit) → review-
Attachment #570508 - Attachment is obsolete: true
Attached patch Patch.V4Splinter Review
I enclosed the content of each <listitem> in <para> tags. Also, I adjusted the indentation per comment 8.
I was able to successfully compile the documentation after making these changes and the resulting PDF matches the desired look as described in the original bug report.
Attachment #631652 - Attachment is obsolete: true
Attachment #636991 - Flags: review?(LpSolit)
Comment on attachment 636991 [details] [diff] [review]
Patch.V4

>=== modified file 'docs/en/xml/administration.xml'

>               The type of field to create. There are
>               several types available:
>+  <variablelist>

The indentation is much better, thanks, but here it looks really weird, as <variablelist> is ~10 characters too far on the left compared to the surrounding text. I will fix that on checkin. The documentation can now compile correctly and the output is fine. Thanks a lot! :) r=LpSolit
Attachment #636991 - Flags: review?(LpSolit) → review+
Assignee: documentation → chtrom
Status: NEW → ASSIGNED
Flags: approval+
Whiteboard: [Good Intro Bug]
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified docs/en/xml/administration.xml
modified docs/en/xml/using.xml
Committed revision 8279.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
The patch applies cleanly to older branches, so let's take it there too. I didn't try to compile the doc on these old branches, because I no longer have jade installed.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified docs/en/xml/administration.xml
modified docs/en/xml/using.xml
Committed revision 8202.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified docs/en/xml/administration.xml
modified docs/en/xml/using.xml
Committed revision 7750.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified docs/en/xml/administration.xml
modified docs/en/xml/using.xml
Committed revision 7317.
Flags: approval4.2+
Flags: approval4.0+
Flags: approval3.6+
Target Milestone: Bugzilla 4.4 → Bugzilla 3.6
Duplicate of this bug: 859721
The PDF are now correctly generated for all branches (I checked them on bugzilla.org).
You need to log in before you can comment on or make changes to this bug.