3.0 menus/dropdowns have a quirk

RESOLVED DUPLICATE of bug 324963

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 324963
11 years ago
11 years ago

People

(Reporter: tommyjb, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006 Minefield/3.0a1

1. Left-click *down* (and don't release yet) on the Tools menu item (for example) in the main window, thereby expanding it.
2. Hover over Options (for example) in this expanded menu and then release the mouse button.

In 1.5 and 2.0 (and pretty much any Windows app), the sub-item will then be activated (*clicked*, effectively).  In 3.0, it won't.

Further, until you release the mouse button, sub-items will *not* be highlighted when the mouse pointer passes over them.  Again, this is not the case with 1.5, 2.0, or any arbitrary Windows app.

This also applies to the search-bar dropdown and the location-bar dropdown (and perhaps others?).

Reproducible: Always
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

*** This bug has been marked as a duplicate of 324963 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.