Addon Manager Drag and Drop Crash [JS_GetPrivate 85cd4a3c]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: osaier, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061007 BonEcho/2.0

Drop at least 1 theme and 2 extensions (whichever) from the Desktop to the addon manager (extension tab) and my Bon echo will invariably crash. No crash in Linux though.
TB24250168H

Reproducible: Always
(Reporter)

Updated

13 years ago
Keywords: crash, talkbackid
(Reporter)

Updated

13 years ago
Summary: Crash when dragging and dropping one theme and two extensions to the addon manager. → Crash when dragging and dropping one theme and two extensions to the addon manager [JS_GetPrivate 85cd4a3c].

Comment 1

13 years ago
Incident ID: 24250168
Stack Signature	JS_GetPrivate 85cd4a3c
Product ID	Firefox2
Build ID	2006100703
Trigger Time	2006-10-07 06:43:07.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	js3250.dll + (00002fa7)
URL visited	
User Comments	drag and drop 2 extensions and one theme to the extension manager.
Since Last Crash	94 sec
Total Uptime	94 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsapi.c, line 2359
Stack Trace 	
JS_GetPrivate  [mozilla/js/src/jsapi.c, line 2359]
nsScriptSecurityManager::GetFramePrincipal  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 2046]
nsScriptSecurityManager::GetPrincipalAndFrame  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 2077]
nsScriptSecurityManager::GetSubjectPrincipal  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 2119]
nsScriptSecurityManager::CheckPropertyAccessImpl  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 615]
nsScriptSecurityManager::CheckPropertyAccess  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 495]
nsScriptSecurityManager::CheckObjectAccess  [mozilla/caps/src/nsScriptSecurityManager.cpp, line 479]
js_InternalGetOrSet  [mozilla/js/src/jsinterp.c, line 1523]
js_GetProperty  [mozilla/js/src/jsobj.c, line 3439]
JS_GetProperty  [mozilla/js/src/jsapi.c, line 2915]
nsXPCWrappedJSClass::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1394]
nsXPCWrappedJS::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 468]
SharedStub  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
nsXULElement::IsFocusable  [mozilla/content/xul/content/src/nsXULElement.cpp, line 645]
nsIFrame::IsFocusable  [mozilla/layout/generic/nsFrame.cpp, line 4783]
nsEventStateManager::PostHandleEvent  [mozilla/content/events/src/nsEventStateManager.cpp, line 2118]
PresShell::HandleEventInternal  [mozilla/layout/base/nsPresShell.cpp, line 6497]
PresShell::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6261]
nsViewManager::HandleEvent  [mozilla/view/src/nsViewManager.cpp, line 2559]
nsViewManager::DispatchEvent  [mozilla/view/src/nsViewManager.cpp, line 2246]
HandleEvent  [mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1377]
nsWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6336]
ChildWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6583]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1565]
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0x89cd (0x77d489cd)
USER32.dll + 0x8a10 (0x77d48a10)
nsAppShell::Run  [mozilla/widget/src/windows/nsAppShell.cpp, line 159]
nsAppStartup::Run  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
main  [mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x16fd7 (0x7c816fd7)
Keywords: talkbackid
Summary: Crash when dragging and dropping one theme and two extensions to the addon manager [JS_GetPrivate 85cd4a3c]. → Crash when dragging and dropping one theme and two extensions to the addon manager [@ JS_GetPrivate]
(Reporter)

Comment 2

13 years ago
Renaming so the stack signature isn't cut.
BTW Minefield 10/7 doesn't crash.
Summary: Crash when dragging and dropping one theme and two extensions to the addon manager [@ JS_GetPrivate] → Addon Manager drag and Drop Crash [JS_GetPrivate 85cd4a3c]
(Reporter)

Updated

13 years ago
Summary: Addon Manager drag and Drop Crash [JS_GetPrivate 85cd4a3c] → Addon Manager Drag and Drop Crash [JS_GetPrivate 85cd4a3c]
Version: unspecified → 2.0 Branch

Comment 3

13 years ago
This bug is an apparent duplicate of Bugzilla bug 269568 because:
A) Stack trace of two bugs is similar and/or identical
B) Steps to reproduce of both bugs is similar and/or identical and/or the steps to reproduce of this bug is a portion of the steps to reproduce of aforementioned bug.
C) The aforementioned bug is older than this bug and has more activity.
D) This bug meets the minimum requirements to be marked as a duplicate under http://www.mozilla.org/quality/help/screening-duplicates.html.

Bug Reporter, if you feel this was done in error PLEASE REOPEN!  We're only human here and bugs occasionally are mismarked.

(This duplication message automatically generated by BugSpeak)

*** This bug has been marked as a duplicate of 269568 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: [dupeme]
(Reporter)

Comment 4

13 years ago
Reopening. Bug 269568 is only seen in Linux and was filled in 2004 whereas this one is only seen in Windows and is relatively new a regression.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

13 years ago
OK, thanks Oliver!  Removing the DUPE note so this bug won't be further prodded.

Robin
Whiteboard: [dupeme]

Comment 6

13 years ago
I can reproduce in "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061014 BonEcho/2.0". 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

13 years ago
(In reply to comment #6)
> I can reproduce in "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1)
> Gecko/20061014 BonEcho/2.0". 
> 

Doesn't crash in Trunk, but seems to be quite defunct.  

Comment 8

13 years ago
I'm tempted to set this as blocking-firefox2.  Please voice your opinion...
I highly suspect this is happening before it ever makes it back to the add-ons mgr. from xpinstall. There are also several other crashes at JS_GetPrivate which this could be a duplicate of.
(Reporter)

Comment 10

11 years ago
Can't reproduce with Fx 3.0.1 on Vista Business SP1, and still OK on Linux.
Status: NEW → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.