Last Comment Bug 355982 - Script("") no longer works
: Script("") no longer works
Status: VERIFIED FIXED
: regression, verified1.8.0.8, verified1.8.1
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Brendan Eich [:brendan]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 355655
  Show dependency treegraph
 
Reported: 2006-10-08 18:03 PDT by shutdown
Modified: 2006-11-09 10:15 PST (History)
0 users
bob: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix to handle null case (1.32 KB, patch)
2006-10-08 21:15 PDT, Brendan Eich [:brendan]
brendan: review+
Details | Diff | Splinter Review

Description shutdown 2006-10-08 18:03:30 PDT
$ dbg.obj/js -e "Script('')"
-e:1: TypeError: self-modifying script detected
Comment 1 Brendan Eich [:brendan] 2006-10-08 21:15:12 PDT
Created attachment 241673 [details] [diff] [review]
fix to handle null case

Sorry about that -- this will be fixed when the bug it blocks is fixed on the 1.8 branch.

/be
Comment 2 Brendan Eich [:brendan] 2006-10-08 21:15:46 PDT
Fixed on trunk:

Checking in jsscript.c;
/cvsroot/mozilla/js/src/jsscript.c,v  <--  jsscript.c
new revision: 3.120; previous revision: 3.119
done

/be
Comment 3 Bob Clary [:bc:] 2006-10-09 06:27:28 PDT
Checking in regress-355982.js;
/cvsroot/mozilla/js/tests/js1_5/Regress/regress-355982.js,v  <--  regress-355982.js
initial revision: 1.1
done
Comment 4 Bob Clary [:bc:] 2006-10-10 00:05:12 PDT
verified fixed 20061009 1.8 windows/linux/mac*, 1.9 windows/linux
Comment 5 Daniel Veditz [:dveditz] 2006-11-01 17:52:11 PST
marking "fixed1.8.0.8" because this was a regression from bug 355655. Checked in with 355655 on the 1.8.0 branch, but should be verified.
Comment 6 Bob Clary [:bc:] 2006-11-09 10:15:51 PST
verified fixed in ff1.5.0.8 release in the browser and 1.8.0.8 20061108 windows/mac*/linux.

Note You need to log in before you can comment on or make changes to this bug.