Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 356004 - "alarmTime has no properties" when opening file from 0.3a1 or older
: "alarmTime has no properties" when opening file from 0.3a1 or older
Status: RESOLVED DUPLICATE of bug 349715
Product: Calendar
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2006-10-09 01:48 PDT by Sascha Nemecek
Modified: 2006-10-11 10:18 PDT (History)
0 users
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description Sascha Nemecek 2006-10-09 01:48:13 PDT
User-Agent:       Opera/9.02 (Windows NT 5.1; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006 Sunbird/0.3

When opening an .ics file from Sunbird 0.3a1 or older the following exeption is displayed: 

"[Exception... "'[JavaScript Error: "alarmTime has no properties" {file: "file:///C:/Programme/Mozilla%20Sunbird%200.3rc2/js/calAlarmService.js" line: 378}]' when calling method: [calIObserver::onAddItem]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/Programme/Mozilla%20Sunbird%200.3rc2/components/calICSCalendar.js :: anonymous :: line 813"  data: yes]"

This error occurs with local and remote ics calendars. 

Reproducible: Sometimes

Steps to Reproduce:
Open .ics file from Sunbird 0.3a1 or older. 
Actual Results:  
An error message is displayed which is not very helpful to the user.

Expected Results:  
a. Be more flexible when reading old .ics files
b. Display the location(s) of the error in the .ics file

Note: The error does not occur with all calendar files. It seems to be related to the datetime format. 

The error number is: 0x80570021
Comment 1 Stefan Sitter 2006-10-10 05:24:05 PDT
Please attach the (anonymized) calendar file that causes this problem to this bug or provide steps how to create such a event/task in Sunbird 0.3a1.
Comment 2 Stefan Sitter 2006-10-11 00:15:21 PDT
Resolving as duplicate of Bug 349715 because I think it's the same underlying problem that should be fixed with the patch in Bug 349715.

*** This bug has been marked as a duplicate of 349715 ***
Comment 3 Sascha Nemecek 2006-10-11 03:25:43 PDT

I just wanted to report that the error messages are gone with the patch proposed in Bug 349715. Sunbird 0.3 is now working as expected. 

Note You need to log in before you can comment on or make changes to this bug.