Closed Bug 356031 Opened 15 years ago Closed 15 years ago

Cannot de-highlight text when browsing back to page with highlighted text

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 263683

People

(Reporter: pufiad, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0

See steps to reproduce.

Reproducible: Always

Steps to Reproduce:
1. Search for some text in a page using the Find bar at the bottom of the screen.
2. Highlight them by clicking the "Highlight all" button or by pressing ctrl-enter.
3. Browse to another page, either by clicking a link, going forward or backward. (The "Highlight all" toggles to disabled and on the new page nothing is highlighted.)
5. Browse back to the previous page (go forward or backward).

Actual Results:  
The "Highlight all" button is still disabled, but the text remains highlighted.

Toggling twice the "Highlight all" button does not de-highlight the text. Searching for another text will highlight both texts!

Expected Results:  
Either one of the following:

[1] The "Highlight all" button should be enabled and toggling it should de-highlight the text;

[2] No text should be highlighted anymore.
This is basically Bug 279022 but is slightly different because the other bug is about switching tabs.
Marking this new as I could not find an exact duplicate.
Status: UNCONFIRMED → NEW
Depends on: 263683, 279022
Ever confirmed: true
Version: unspecified → Trunk
Thank you, Ria. I'll add a comment to the other one. The behaviour is very similar indeed.

*** This bug has been marked as a duplicate of 263683 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
No longer depends on: 263683, 279022
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.