Closed Bug 356150 Opened 14 years ago Closed 14 years ago

Necko code should support the use of SRV records to look up service endpoints

Categories

(Core :: Networking, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 14328

People

(Reporter: usenet, Unassigned)

Details

SRV DNS records (see RFC 2782) allow delegation on a per-protocol basis, and can thus provide support for redirection, load-balancing and failover on a per-service basis.

Although SRV records are currently little-used, this is a chicken-and-egg issue because there is little software support for them. SRV records will become more important in future, as newer protocols such as SIP emerge which are designed to use SRV records. 

Implementing this will require DNS resolver support for multiple record types; see bug 356104.
Neil: could you please file Networking bugs in Core::Networking instead of Firefox::General? You should be able to do that by using https://bugzilla.mozilla.org/enter_bug.cgi?product=Core to file the bugs. Thanks.
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Sorry about that: I did it once or twice, but the main bug-submission interface seemed to be designed to stop me from doing it easily, so I presumed that I was _supposed_ to submit things under the general categories, and then to let other people triage it.

I'll file them all as Core/Networking bugs from now on... 
Reporter, always search before you file a bug.

*** This bug has been marked as a duplicate of 14328 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.