Closed Bug 356183 Opened 13 years ago Closed 13 years ago

CalDAV provider throws on retrieval of VTODOs

Categories

(Calendar :: Provider: CalDAV, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: browning, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060614 Fedora/1.5.0.4-1.2.fc5 Firefox/1.5.0.4 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061006 Sunbird/0.3

The Darwin CalendarServer is the first of the CalDAV servers "commonly" used with Sunbird that supports VTODOs. Sunbird can place VTODO items in a CalendarServer repostitory but throws when trying to retrieve them.

Reproducible: Always

Steps to Reproduce:
1. Using Sunbird, create a VTODO item on a CalendarServer repository
2. Exit/restart Sunbird
3.

Actual Results:  
Item does not appear in Tasks list
In Error Console: Error: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: file:///home/bruno/dloads/sunbird/components/calDavCalendar.js :: anonymous :: line 720"  data: no]
Source File: file:///home/bruno/dloads/sunbird/components/calDavCalendar.js
Line: 720

Expected Results:  
Item should appear in Task list
No errors in Error Console

patch forthcoming. FWIW, I don't think this should have any impact whatsoever on release of 0.3: I just want to get it in the queue.
if an item is a vtodo, "item.QueryInterface(Ci.calIEvent)" throws, "item instanceof Ci.calIEvent" returns false. Seems to me we need the latter.
Attachment #241842 - Flags: second-review?(dmose)
Attachment #241842 - Flags: first-review?(lilmatt)
Comment on attachment 241842 [details] [diff] [review]
instanceof instead of QueryInterface

r=lilmatt for post 0.3
Attachment #241842 - Flags: first-review?(lilmatt) → first-review+
Comment on attachment 241842 [details] [diff] [review]
instanceof instead of QueryInterface

Moving r2 to jminta per dmose
Attachment #241842 - Flags: second-review?(dmose) → second-review?(jminta)
Comment on attachment 241842 [details] [diff] [review]
instanceof instead of QueryInterface

sweetness. r2=jminta
Attachment #241842 - Flags: second-review?(jminta) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Looks like patch was misapplied.
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/calendar/providers/caldav&command=DIFF_FRAMESET&file=calDavCalendar.js&rev1=1.75&rev2=1.76&root=/cvsroot
http://lxr.mozilla.org/mozilla/source/calendar/providers/caldav/calDavCalendar.js#721

Patch says should be 
   item instanceof
but result is
   item.instanceof
-------^

Result is 

  Error: missing ) after condition
  Source File: file:///C:/moz/sunbird/components/calDavCalendar.js
  Line: 720, Column: 43
  Source Code:
                } else if (item.instanceof Ci.calIEvent) {
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I commited a fix for that an hour or so ago.

-> FIXED
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.