All users were logged out of Bugzilla on October 13th, 2018

Year in printout is not changed when entering the new year.

VERIFIED FIXED

Status

VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: news4marius, Assigned: jminta)

Tracking

Trunk
x86
Windows 2000

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

When a printout is made of a period which ends in a later year the year in the printout is not changed. So nov 2006 thru feb 2007 will print as nov 2006, dec 2006, jan 2006, feb 2006. The calendar itself is correct.

Reproducible: Always

Steps to Reproduce:
1. Choose Print in File menu
2. Change Layout in "Monthly Grid"
3. Choose a custom date range which includes december and january of the following year
4. Print
5. Examine the output.

Actual Results:  
No change in year in header.

Expected Results:  
Print the proper year.

Will add the output as a pdf file.
(Reporter)

Comment 1

12 years ago
Created attachment 241915 [details]
PDF file with print output

Hope it is clear enough.

Comment 2

12 years ago
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9a1) Gecko/20061006 Sunbird/0.3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Assignee)

Comment 3

12 years ago
Created attachment 241931 [details] [diff] [review]
use date not start

Pretty self-explanatory.  We're iterating over |date|, not |start|.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #241931 - Flags: second-review?(dmose)
Attachment #241931 - Flags: first-review?
Comment on attachment 241931 [details] [diff] [review]
use date not start

r=lilmatt
Attachment #241931 - Flags: first-review? → first-review+
Comment on attachment 241931 [details] [diff] [review]
use date not start

r1/2=lilmatt (with dmose's blessing for me to do the r2)
Attachment #241931 - Flags: second-review?(dmose) → second-review+
(Assignee)

Comment 6

12 years ago
Patch checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Whiteboard: [litmus testcase wanted]

Updated

12 years ago
Status: RESOLVED → VERIFIED
*** Bug 361473 has been marked as a duplicate of this bug. ***
*** Bug 362046 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 366253

Comment 10

12 years ago
Litmus testcase 3010 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.