Closed Bug 356261 Opened 13 years ago Closed 13 years ago

lightning-wcap builds don't function properly

Categories

(Calendar :: Lightning Only, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
Lightning 0.3

People

(Reporter: dbo, Assigned: mattwillis)

References

Details

(Whiteboard: [verified0.3.1])

Attachments

(1 file)

Some users reported that they face the problem that the lightning-wcap builds don't function correctly, i.e. they have to manually set the missing calendar.wcap.enabled resp. calendar.prototypes.wcap prefs.
However I couldn't reproduce that problem on my TB 1.5.0.7, I assume it relates to a different installation order of the two inherent packages, i.e. wcap-enabler.xpi is installed *before* lightning.xpi where the latter sets the pref to false.

A solution I can imagine is to omit setting those two prefs explicitly to false in calendar/lightning/content/lightning.js. This is no problem, because the corresponding code reading those pref is graceful if those prefs do not exist (assuming they are false).
Fixed in the 0.3 lightning-wcap builds only.
Assignee: nobody → lilmatt
Status: NEW → ASSIGNED
Attachment #241946 - Flags: first-review?(dmose)
Comment on attachment 241946 [details] [diff] [review]
removes prefs that by default disable wcap stuff

r=dmose, once we've verified with the new 0.3 wcap builds that this change actually fixes the issue.
Attachment #241946 - Flags: first-review?(dmose) → first-review+
ssa verified it fixes the issue.

Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: blocking-calendar0.3.1?
IMO it's sensible to take this patch for 0.3.1.
Flags: blocking-calendar0.3.1? → blocking-calendar0.3.1+
Patch checked in for 0.3.1

LIGHTNING_0_3_BRANCH:
Checking in lightning.js;
/cvsroot/mozilla/calendar/lightning/content/lightning.js,v  <--  lightning.js
new revision: 1.2.2.8.2.1; previous revision: 1.2.2.8

SUNBIRD_0_3_BRANCH:
Checking in lightning.js;
/cvsroot/mozilla/calendar/lightning/content/lightning.js,v  <--  lightning.js
new revision: 1.8.2.1; previous revision: 1.8

Marking [fixed0.3.1]
Whiteboard: [fixed0.3.1]
Not going to mark this as Verified, since I'm not totally clear on how to reproduce the scenario.  But, I will add that WCAP 0.3.1 is working for me on Tbird 1.5.9. Thunderbird: version 1.5.0.9 (20061207) Lightning 0.3.1 + WCAP: 2007020304.

--> VERIFIED?
fix verified in lightning 0.3.1 (build 20070203).
Status: RESOLVED → VERIFIED
Whiteboard: [fixed0.3.1] → [verified0.3.1]
Duplicate of this bug: 363949
You need to log in before you can comment on or make changes to this bug.