Bugzilla overly dependent on bug status names (hard coded workflow)

RESOLVED DUPLICATE of bug 101179

Status

()

Bugzilla
Administration
--
major
RESOLVED DUPLICATE of bug 101179
12 years ago
12 years ago

People

(Reporter: Kevin Benton, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
There are a number of files in Bugzilla that continue to rely on certain status names such as NEW or REOPENED.  For example, whineatnews.pl has no way to recognize statuses that it should whine about except that they're hard coded in the program.  Checksetup.pl doesn't allow for workflow apart from the pre-defined workflow published in our docs.  post_bug.cgi only allows for NEW and UNCONFIRMED.  Many of the templates seem to have all the status values hard coded into them as well.  This prevents users from being able to effectively add new statuses and clearly prevents them from renaming existing statuses.  I think that where we are now is a good step toward customizable work flows, but at this point (2.22), there's a lot more work to do.

Comment 1

12 years ago
This will be fixed by bug 101179

*** This bug has been marked as a duplicate of 101179 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.