All users were logged out of Bugzilla on October 13th, 2018

network connections are not properly closed

VERIFIED INVALID

Status

()

P3
major
VERIFIED INVALID
19 years ago
19 years ago

People

(Reporter: jer, Assigned: gagan)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
On the nightly with build ID 2000041205, you only need to load a small number of
websites before this becomes really evident. Mozilla isn't properly closing its
network connections. Once enough are open, you get a TCP - Not enough memory error.

netstat gives a whole lot of lines like the following:

TCP	(my hostname:port)	(remote address:80)	CLOSE_WAIT

After exitting Mozilla, all the connections will disappear from the netstat listing.
(Reporter)

Comment 1

19 years ago
As a followup to this, the number of still active connections balloons much 
faster in the original window than in any new windows, although it will still 
slowly increase as you browse in them.

I don't think it's relevent, but the TCP Error: Not enough memory only comes up 
once there are 93 network connections.

Comment 2

19 years ago
This remembers me of bug 35150, but that is marked fixed 4/11.
Maybe this fix has something to do with this...

Comment 3

19 years ago
Actually it will keep up to keep-alive.max-connections (default is 30) open
connections in the keep-alive queue. So, it's normal (there was a leak before 
which was fixed).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

19 years ago
verified, since today's 10am build no longer has the problem.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.