If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Nightly build directories sorted per platform and branch

RESOLVED DUPLICATE of bug 413572

Status

Release Engineering
General
P3
enhancement
RESOLVED DUPLICATE of bug 413572
11 years ago
4 years ago

People

(Reporter: mats, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
I would very much like to have a directory where I can find nightly builds
for a specific platform/branch. For example something like this:

http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/mac/trunk/
   2006-08-12-06/
     seamonkey-1.5a.en-US.mac.dmg
   2006-08-31-16/
     seamonkey-1.5a.en-US.mac.dmg
   ...

http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/mac/branch-1.8/
   2006-10-01-13/
     seamonkey-1.5a.en-US.mac.dmg
   2006-10-02-14
     seamonkey-1.5a.en-US.mac.dmg
   ...

and the same for other "platforms", e.g.
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/win32/trunk/
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/gtk1/trunk/
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/gtk2/trunk/
etc.

This would make it easier to find which builds are available when
testing when a specific regression occurred.

(I think this can be implemented using symlinks so the disk space
cost would be low)

Comment 1

11 years ago
This is really more of a build/release RFE then staging.
Assignee: zach → build
Component: FTP: Staging → Build & Release
QA Contact: myk → preed

Updated

10 years ago
Priority: -- → P3
Assignee: build → nobody
QA Contact: mozpreed → build
Is this still an issue ? Would something like bug 413572 be helpful ?
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Is this still an issue ?

Yes.

> Would something like bug 413572 be helpful ?

Yes, the "View all available builds" on http://nightly.webkit.org/
is somewhat what I had in mind.
Ok, I'm going to dupe forward then. Help welcome there.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 413572
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.