Last Comment Bug 356694 - Flash doesn't work on Intel Macs, problems with "Flash Player Enabler.plugin" (which is PowerPC)
: Flash doesn't work on Intel Macs, problems with "Flash Player Enabler.plugin"...
Status: VERIFIED FIXED
[Fx 2.0.0.1]
: relnote, verified1.8.1.1
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 1.8 Branch
: PowerPC Mac OS X
: -- major (vote)
: ---
Assigned To: Josh Aas
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://youtube.com/
Depends on:
Blocks: 359873
  Show dependency treegraph
 
Reported: 2006-10-14 16:30 PDT by Judson Valeski
Modified: 2006-12-01 11:21 PST (History)
10 users (show)
mbeltzner: blocking1.8.1-
dveditz: blocking1.8.1.1+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
the PowerPC plugin enabler that was giving me trouble. (6.00 KB, application/zip)
2006-10-18 09:01 PDT, Judson Valeski
no flags Details
back this out, patch -R (2.64 KB, patch)
2006-11-07 11:42 PST, Josh Aas
sayrer: review+
jst: superreview+
dveditz: approval1.8.1.1+
Details | Diff | Splinter Review

Description Judson Valeski 2006-10-14 16:30:51 PDT
Since updating to Firefox 2 rc2, Flash doesn't work on any sites. I've tried upgrading my flash player (currently 9.0 r19), and still no dice.

Steps to reproduce:
1. load said URL
2. click on any of the video thumbnails.
3. notice the player doesn't load.
4. notice no Flash context menu appears when you ctrl-click (right click) in the expected flash area.

Although I can't view the article, this macfixit title seems to imply others are having issues too. http://www.macfixit.com/article.php?story=20060905094554613
Comment 1 Judson Valeski 2006-10-14 16:32:09 PDT
this was happening in 10.4.7 OSX also; before I upgraded to .8
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-10-14 23:04:44 PDT
Does it work in Safe mode? http://kb.mozillazine.org/Safe_mode
Comment 3 Judson Valeski 2006-10-15 06:58:42 PDT
did not know about safe mode; now I do; thanks! however, safe mode did not solve the problem unfortunately.
Comment 4 Judson Valeski 2006-10-15 07:08:10 PDT
This bug exists on my Intel based Mac (MacBook), running OSX 10.4.8, FFox2rc2, Flash 9.0 r19 (highest version).

This bug DOES NOT exist on my PowerPC based Mac (iMac), running OSX 10.4.8, FFox2rc2, Flash 9.0 r16 (highest version).
Comment 5 (not reading, please use seth@sspitzer.org instead) 2006-10-15 09:34:51 PDT
data point:  I've just upgraded to 9.0r20 on my intel mac running FF2 (version number coming next) and it works for me.

Shockwave Flash

    File name: Flash Player.plugin
    Shockwave Flash 9.0 r20

MIME Type 	Description 	Suffixes 	Enabled
application/x-shockwave-flash 	Shockwave Flash 	swf 	Yes
application/futuresplash 	FutureSplash Player 	spl 	Yes

jud tells me there are reports of problems on macfixit, I'll look for more details.
Comment 6 (not reading, please use seth@sspitzer.org instead) 2006-10-15 09:56:07 PDT
the version of firefox I am using is:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0

I got the new version of flash from http://www.adobe.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash&P2_Platform=MacOSX

(I used to be running Flash 8.0 r27, which also worked for me.)

jud, can you try upgrading to 9r20?



Comment 7 (not reading, please use seth@sspitzer.org instead) 2006-10-15 10:01:03 PDT
jud, is http://forums.mozillazine.org/viewtopic.php?t=472272&highlight=flash+mac similar to what you are seeing?

are you seeing anything in the console if you do:

1) launch Terminal
2) from your shell, do:  /Applications/Firefox.app/Contents/MacOS/firefox-bin 
Comment 8 Judson Valeski 2006-10-15 10:46:30 PDT
That mozillazine article is what I'm seeing too.

I'm on flash 9r20 now, but just noticed that I appear to have two things registered for flash.

Shockwave Flash

    File name: Flash Player Enabler.plugin
    Shockwave Flash 9.0 r19

MIME Type 	Description 	Suffixes 	Enabled
application/x-shockwave-flash 	Shockwave Flash 	swf 	Yes
application/futuresplash 	FutureSplash Player 	spl 	Yes
Shockwave Flash

    File name: Flash Player.plugin
    Shockwave Flash 9.0 r20

MIME Type 	Description 	Suffixes 	Enabled
application/x-shockwave-flash 	Shockwave Flash 	swf 	Yes
application/futuresplash 	FutureSplash Player 	spl 	Yes
Comment 9 Judson Valeski 2006-10-15 10:50:40 PDT
I moved the "Flash Player Enabler.plugin" out of the way, and all is well. I did not make any changes to my plugins prior to upgrading to FF2rc2, so this still feels like a bug to me.
Comment 10 (not reading, please use seth@sspitzer.org instead) 2006-10-16 10:06:45 PDT
from http://www.flip4mac.com/fusetalk/forum/messageview.aspx?catid=32&threadid=1524&enterthread=y

Just noticed that by "getting info" for the Flash plug-ins, the Flash Player Enabler.plugin "Kind" is "Plug-in (PowerPC)" and the Flash Player.plugin is "Plug-in (Universal)". What is a PowerPC plug-in doing there? Can That be the problem? I followed the standard installation instructions of Adobe. Thanks for your time and patience. We may be getting to the bottom of this. 

jud, can you see if your "Flash Player Enabler.plugin" (Shockwave Flash 9.0 r19) is a PowerPC plugin?
Comment 11 Judson Valeski 2006-10-17 09:55:03 PDT
mine, which I moved out the way (e.g. not using now), is indeed PowerPC.
Comment 12 Jay 2006-10-18 04:24:32 PDT
Running Firefox 2.0 RC3 since updating to this I get the error below.

Cannot recognize type of executable for CFBundle 0x18704890 </Library/Internet Plug-Ins/Flash Player Enabler.plugin> (not loaded)

I have already tried reinstalling the universal binary version of flash with no success.  Running OS X 10.4.8 on an Intel iMac.
Comment 13 (not reading, please use seth@sspitzer.org instead) 2006-10-18 08:52:57 PDT
jay / judson:  before flash stopped working, what version of Firefox were you using?

(Was it OK with FF 2.0 RC 2 or RC 1?)

From the forum link cited above (http://forums.mozillazine.org/viewtopic.php?t=472272&highlight=flash+mac):

"Since updating (automatically) to the new FF 2.0 RC2 this morning (07 Oct 2006 05:41 pm) flash no longer works"
Comment 14 Judson Valeski 2006-10-18 08:55:20 PDT
broke for me when auto-update from rc1 to rc2.
Comment 15 (not reading, please use seth@sspitzer.org instead) 2006-10-18 08:57:01 PDT
thanks for the info, jud.

Can you zip up your "Flash Player Enabler.plugin" and attach it here? 
Comment 16 Judson Valeski 2006-10-18 09:01:05 PDT
Created attachment 242640 [details]
the PowerPC plugin enabler that was giving me trouble.
Comment 17 Tim Riley [:timr] 2006-10-18 09:57:58 PDT
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

WFM.  I updated from RC1 ->RC3.  Flash worked in RC1 and still worked in RC3.  However, I have Flash 9 r20 installed.

Shockwave Flash

    File name: Flash Player.plugin
    Shockwave Flash 9.0 r20
Comment 18 (not reading, please use seth@sspitzer.org instead) 2006-10-18 10:02:11 PDT
> WFM.  I updated from RC1 ->RC3.  Flash worked in RC1 and still worked in RC3. 
> However, I have Flash 9 r20 installed.

it WFM, too.  

But it's the PowerPC "Flash Player Enabler.plugin" that is tripping us up.
Comment 19 Jay 2006-10-18 10:38:45 PDT
I upgraded from 1.5.0.7 and flash was working fine.
Comment 20 (not reading, please use seth@sspitzer.org instead) 2006-10-18 11:36:40 PDT
dan pointed me to bug #302737 and bug #354124.

I'll try to see if this is the same issue or not, by reproducing the bug with jud's plugin and FF2.0RC2 and then testing with RC3.
Comment 21 (not reading, please use seth@sspitzer.org instead) 2006-10-18 15:00:55 PDT
jud, where was "Flash Player Enabler.plugin" located for you?

/Library/Internet Plug-Ins/, or somewhere else?

Comment 22 Judson Valeski 2006-10-18 15:14:12 PDT
that's where it used to be... I moved it to my Documents folder so I could get things working again.
Comment 23 (not reading, please use seth@sspitzer.org instead) 2006-10-18 20:38:38 PDT
> that's where it used to be.

Thanks jud.  the reason I ask is that I have the same "enabler" plugin, but it doesn't show for me in about:plugins

just for extra some background info on this plugin and the files, see http://weblogs.macromedia.com/mesh/archives/2006/01/flash_player_sw.html
Comment 24 Smokey Ardisson (offline for a while; not following bugs - do not email) 2006-10-19 12:45:55 PDT
One thing I've noticed (and it's not clear to me from the discussion whether it's relevant here or not; sorry) is that the Flash Player installer often only updates "half" of an existing Flash Plugin install, so you end up with one file that's from 8.0 and another from 9.0, etc.--and potentially one Universal and one PPC-only.

So I've taken to completely removing Flash Plugin files from /Library/Internet Plug-ins before installing a new version.  I don't have an Intel Mac, so I can't tell if the Enabler.plugin is supposed to be Uni or not.
Comment 25 Mike Schroepfer 2006-10-19 17:39:00 PDT
Josh - any thoughts on this?
Comment 26 Mike Beltzner [:beltzner, not reading bugmail] 2006-10-19 17:39:14 PDT
Minusing for 1.8.1 but adding relnote comment.
Nominating for 1.8.1.1.

Better STR would help me with the release notes! :)
Comment 27 Judson Valeski 2006-11-04 20:42:31 PST
I think I found the culprit here... Both Intel machines that I've now seen this on (just experienced it on my new home iMac) were migrated to from previous PowerPC machines. I used the Apple migration assistant to migrate from PowerPC machines to Intel machines. The assistant must be carrying over the PowerPC Flash Player Enabler.plugin to the new, Intel, mac. Not sure how the migration asst works, but it shouldn't be carrying over bits that don't run on Intel.
Comment 28 (not reading, please use seth@sspitzer.org instead) 2006-11-06 10:33:43 PST
jud, thanks for the additional info.

fwiw, on my Intel Mac, I have a "/Library/Internet Plug-Ins/Flash Player Enabler.plugin", and I did not migrate from a PowerPC mac.  Just having the "Flash Player Enabler.plugin" isn't enough to cause this bug.

perhaps we should add code to ignore any PowerPC plugins on Mac Intel?

(file for "Flash Player Enabler.plugin/Contents/MacOS/Flash Player Enabler" returns "header for PowerPC PEF executable")
Comment 29 lolife 2006-11-07 09:39:15 PST
What should be of interest to the Mozilla team is that Flash works fine on Safari without jumping through any of these hoops. Firefox breaks, Safari doesn't. That should be a worthwhile data point.

I finally got mine working be deleting every file I could find with the word "flash" in it:

   659  11:29   sudo rm -rf /Applications/SAFlashPlayer
   660  11:29   sudo rm -rf /Library/Application\ Support/Macromedia/Shockwave\ 10/
   661  11:30   sudo rm -rf /Library/Internet\ Plug-Ins/Flash\ Player*
   662  11:30   sudo rm -rf /Library/Internet\ Plug-Ins/flashplayer.xpt
   664  11:30   sudo rm -rf /Library/Internet\ Plug-Ins/NP-PPC-Dir-Shockwave
   665  11:30   rm -rf Library/Internet\ Plug-Ins/*
   666  11:31   rm -rf Library/Caches/Java\ Applets/cache/javapi/v1.0/file/flashpro.class-4e8ff740-28ffe73f.*
   669  11:34   rm -rf Library/Application\ Support/Firefox/pluginreg.dat
Comment 30 (not reading, please use seth@sspitzer.org instead) 2006-11-07 09:55:57 PST
thanks for the additional info, lolife.

jud, can you attach your ~/Library/Application\ Support/Firefox/pluginreg.dat or email it to me?

I am wondering if your pluginreg.dat (since you used the migration assistant to go from PowerPC to Intel) contains a reference to the PowerPC based "Flash Player Enabler.plugin".
Comment 31 (not reading, please use seth@sspitzer.org instead) 2006-11-07 10:04:44 PST
if that is it, we might be able to add some ifdef XP_MACOS_X code to nsPluginHostImpl.cpp to use nsILocalFileMac::GetFileType() to determine if the plugins are all safe for the current architecture, and if not, rebuild the pluginreg.dat file

http://lxr.mozilla.org/seamonkey/source/modules/plugin/base/src/nsPluginHostImpl.cpp#234
http://lxr.mozilla.org/seamonkey/source/xpcom/io/nsLocalFileMac.cpp#3165

Comment 32 Josh Aas 2006-11-07 11:00:34 PST
When pluginreg.dat is generated on a PPC machine you can't use it on an Intel
machine in this case. Delete pluginreg.dat to fix the problem.

We should probably run loadability checks on plugins every time instead of
relying on the cache, otherwise we'll run into problem like this. Working on
it...
Comment 33 (not reading, please use seth@sspitzer.org instead) 2006-11-07 11:07:12 PST
more info from josh over AIM:

I think you're onto something with pluginreg.dat.  the enabler file is not just the trigger.  

we have code that checks the plugin arch before loading it and skips it if it can't execute.  

I wrote that code myself, nsPluginsDirDarwin.cpp
IsLoadablePlugin()

if you wipe out your profile then force FF to run as a PPC app, then use that plugin.dat, I bet you'll repro.

the trick for forcing FF to run as a PPC app is to do "Get Info" on the app and check "Run in Rosetta".

I can repro with those exact steps.
Comment 34 (not reading, please use seth@sspitzer.org instead) 2006-11-07 11:36:16 PST
from https://bugzilla.mozilla.org/show_bug.cgi?id=346954#c20

"it just moves IsPluginFile() calls after the cache check).

Benefits: avoid inspecting executables we already know are plugins (because
they're in the cache)."

this assumption may be the cause of the problem, because as josh/jud have found, the plugins in the cache may not be valid, due to migration.
Comment 35 Josh Aas 2006-11-07 11:42:54 PST
Created attachment 244913 [details] [diff] [review]
back this out, patch -R
Comment 36 (not reading, please use seth@sspitzer.org instead) 2006-11-07 11:49:51 PST
if sayrer is OK with the backout, I'd recommend adding a comment about why we need to call IsPluginFile() where we call it, and refer back to this bug.
Comment 37 Robert Sayre 2006-11-07 11:53:23 PST
Comment on attachment 244913 [details] [diff] [review]
back this out, patch -R

this rots... but we should fix this ASAP.

drivers: this will cause at least one safari plugin to get loaded every time a feed is visited.
Comment 38 Josh Aas 2006-11-07 12:02:12 PST
"this will cause at least one safari plugin to get loaded every time a
feed is visited."

That was fixed by the first patch on the other bug. we're only backing out the second patch, so that shouldn't happen.
Comment 39 Robert Sayre 2006-11-07 12:04:11 PST
(In reply to comment #38)
>
> That was fixed by the first patch on the other bug. we're only backing out the
> second patch, so that shouldn't happen.

Yes, you're right. It will cause some plugins to be loaded every time a feed is visited, but nothing really common AFAIK (the other patch in the old bug prevents the Safari plugin problem).  

Comment 40 (not reading, please use seth@sspitzer.org instead) 2006-11-07 12:16:18 PST
just to clarify (in case I wasn't the only one who got confused)

backing out part 2 of sayrer's 2 part fix for bug #346954 will, to quote robert from irc:  "will regress part of it, but not the worst part.  so it's livable"
Comment 41 Johnny Stenback (:jst, jst@mozilla.com) 2006-11-07 20:23:00 PST
Comment on attachment 244913 [details] [diff] [review]
back this out, patch -R

sr=jst
Comment 42 Josh Aas 2006-11-08 08:43:42 PST
landed on trunk
Comment 43 Daniel Veditz [:dveditz] 2006-11-20 12:23:46 PST
Comment on attachment 244913 [details] [diff] [review]
back this out, patch -R

approved for 1.8 branch, a=dveditz for drivers
Comment 44 Josh Aas 2006-11-20 16:41:20 PST
landed on 1.8 branch
Comment 45 Chris Cooper [:coop] 2006-12-01 11:12:33 PST
WFM:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1pre) Gecko/20061130 BonEcho/2.0.0.1pre

Note You need to log in before you can comment on or make changes to this bug.