Daily recurring allday event adds 1 day

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: ohgary, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061010 Sunbird/0.3

Click on a data -> New Event, put in a title, click all day -> click repeat -> click set pattern. In the Edit recurrence set daily, every 1 day, repeat until. Select a 6 day period My example was Dec 4th through Dec 10th of 2006.  Click ok on the edit window and ok on the new event. 
 You end up with a repeateing date Dec 4th,5,6,7,8,9,10 and 11th. No mater what your end date you get an extra date.

Reproducible: Always

Steps to Reproduce:
See details.
Actual Results:  
 a 6 day event is 7 days long, 7 day event is 8.. always one more event.

Expected Results:  
When I says repeater until, then the until date should be the late date I see the event.
I tried to reproduce with normal and with all-day event and it works for me. Please export the event/task in question to iCalendar format and attach to this bug.

Comment 2

13 years ago
Works for me too
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061027 Calendar/0.4a1
(Reporter)

Comment 3

13 years ago
As requested here is an example of the problem I see
Attachment #243905 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 243905 [details]
An example of 1 day extra repeat

This attachment just shows an single all-day event on 28-Oct-2006. There is no sign of repeating and it's not a task as written in summary. Have you attached the correct event?
(Reporter)

Comment 5

13 years ago

Comment 6

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061201 Calendar/0.4a1

I was able to reproduce this bug by following the steps described by the creator.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Ok, this seems to be another timezone issue. 
My local timezone is CET (UTC+1). Using this settings I can't reproduce the problem. But if I set my system to UTC-1 I can reproduce the problem.

Isn't there some magic about the until date always being UTC or similiar?

Comment 8

12 years ago
I can reproduce this using Lightning 0.7pre 2007072204 and a timezone of UTC-4.  In the prototype event dialog the text description says "Occurs every day effective 26-Jul-2007 until 01-Aug-2007", but the month views shows the event from 26 Jul through 02 Aug.

This is possibly a duplicate of bug 353887, where Clint wrote:

"Bug is only reproducible in the case where you have recurring, all-day events
and a RECURUNTIL date that is <= 24 hours from an occurrence of the event."

Updated

12 years ago
Attachment #243925 - Attachment mime type: application/octet-stream → text/calendar

Updated

12 years ago
Depends on: 353887
Summary: New task for multi days adds 1 day. → Daily recurring allday event adds 1 day

Updated

12 years ago
Attachment #243925 - Attachment mime type: text/calendar → text/plain

Comment 9

12 years ago
I am experiencing this without setting it as a "recurring event".

If I create a new event with Sunbird 0.7/Windows XP, and select "All Day Event", it makes the event two days long. Adding an extra day to it. If I try and edit the dates manually, to make the day the same i.e. Start: 15/11/07 End: 15/11/07. And click "Save And Close", it does not workaround the bug. It will still make it an all day event spanning two days.
Possibly fixed with bug 333363 or bug 353887.
Reporter, could you please check the upcoming nightly builds whether this bug has been fixed?

Comment 11

11 years ago

I have a bug i noticed since 0.7 and persist here in 0.8 rc2. It's the only thing that preventing me kicking the infamous ass of Evolution and stick to Mozilla's.

The thing is, synching my palm pilot with evolution data server using gpilot generates an ics file. That ics file is now transparently readable for lightning 0.8 rc2 (for 0.7 I had to "sed it" in the timezones to work), but does not import well the daily repeating events (the ones with the flag UNTIL=20080321, for example) Lightning ends the repetition of the event one day before the actual "until day", but if you double-click the event, the correct date will show in the repetition behavior resume. And if you edit that behavior, you will see that actually in the editor, the date is wrong (one day before) and you have to correct it (i'm not willing to correct every daily-repeating event everytime i sync my palm), once corrected, if you open the ics file, it shows the "UNTIL" flag ONE DAY AFTER!!!!!, of course i could make a script to search de UNTIL flag and change it one day after for sunbird show the same info as my palm... but... I think this is a bug and have to be fixed.

Cheers!
Comment 11 sounds like a different issue. Marking WFM, please reopen if this problem persists.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.