Closed Bug 35692 Opened 25 years ago Closed 25 years ago

Browser falls into an infinite loop

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 31378

People

(Reporter: newton, Assigned: rogerl)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD 5.0-CURRENT i386; en-US; m14)
BuildID:    2000030708

Browser loops continually, delivering these messages on stderr:

WEBSHELL+ = 10
WEBSHELL+ = 11
WEBSHELL+ = 12
WEBSHELL+ = 13
WEBSHELL+ = 14
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (4.712 secs)
Error loading URL
http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
Document: Done (2.001 secs)
WEBSHELL+ = 15
WEBSHELL+ = 16
WEBSHELL+ = 17
WEBSHELL+ = 18
WEBSHELL+ = 19
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (4.7 secs)
Error loading URL
http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
Document: Done (1.951 secs)
WEBSHELL+ = 20
WEBSHELL+ = 21
WEBSHELL+ = 22
WEBSHELL+ = 23
WEBSHELL+ = 24
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (4.462 secs)
Error loading URL
http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
Document: Done (1.887 secs)
WEBSHELL+ = 25
WEBSHELL+ = 26
WEBSHELL+ = 27
WEBSHELL+ = 28
WEBSHELL+ = 29
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (4.637 secs)
Error loading URL
http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
Document: Done (1.879 secs)
WEBSHELL+ = 30
WEBSHELL+ = 31
WEBSHELL+ = 32
WEBSHELL+ = 33
WEBSHELL+ = 34
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (4.66 secs)
Error loading URL
http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
Document: Done (1.894 secs)
WEBSHELL+ = 35
WEBSHELL+ = 36
WEBSHELL+ = 37
WEBSHELL+ = 38
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (6.62 secs)
WEBSHELL+ = 39
Error loading URL
http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
Document: Done (1.986 secs)
WEBSHELL+ = 40
WEBSHELL+ = 41
WEBSHELL+ = 42
WEBSHELL+ = 43
WEBSHELL+ = 44
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (5.108 secs)
Error loading URL
http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
Document: Done (1.854 secs)
WEBSHELL+ = 45
WEBSHELL+ = 46
WEBSHELL+ = 47
WEBSHELL+ = 48
WEBSHELL+ = 49
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (4.797 secs)
Error loading URL
http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
Document: Done (1.969 secs)
Going to Stop
Error loading URL http://www.atomfilms.com/channels/channel_daily.asp
Document: Done (1.792 secs)
CSSLoaderImpl::DidLoadStyle: Load of URL
'http://www.atomfilms.com/ns_atomfilms.css' failed.  Error code: 2




Reproducible: Always
Steps to Reproduce:
1.Enter "http://www.atomfilms.co.uk/" into the location bar.



Actual Results:  Viewer divides into three frames.  Top and bottom frame load
their content, centre frame remains blank.  An iteration of the errors above are
displayed on stderr, the screen clears, and the loop begins anew.



Expected Results:  Mozilla should have displayed the page :-)
The JS at http://www.atomfilms.com/state.asp?furl=/channels/channel_daily.asp
contains
parent.content.location.replace("/channels/channel_daily.asp");

I seem to recall a bug report about "content" being a new reserved identifier. 
And in fact, one of the main frames is called "content".
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: FreeBSD → All
danm owns a bug on this. setting QA contact, component.

*** This bug has been marked as a duplicate of 31378 ***
Status: NEW → RESOLVED
Closed: 25 years ago
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale
Resolution: --- → DUPLICATE
Duplicate verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.