Closed Bug 357145 Opened 13 years ago Closed 10 years ago

code cleanup: switch from %S %S to %1$S %2$S in updates.properties and add comments for localizers

Categories

(Toolkit :: Application Update, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: moco, Unassigned)

References

()

Details

code cleanup:  switch from %S %S -> %1$S %2$S in updates.properties and add comments for localizers

this comes from dan's review of my patch for bug #329729

> Shouldn't these double-replacements use the %1$S %2$S syntax, plus
> a comment explaining to the translators what each part is?

Yes, you are right.  I'm not sure what I was thinking, other than I was following the existing updateName properties.

on the MOZILLA_1_8_0_BRANCH, I added these three comments before checking in:

# Note to localizers:  %S %S will become something like "Firefox 2.0"
introType_major_app_and_version=You can download and install %S %S now!
# Note to localizers:  %S %S will become something like "Firefox 2.0"
licenseContentDownloading=Getting license for %S %S...
# Note to localizers:  %S %S will become something like "Firefox 2.0"
updateMoreInfoContentDownloading=Getting more details about %S %S...

Note, see also:

http://lxr.mozilla.org/seamonkey/source/toolkit/locales/en-US/chrome/mozapps/extensions/extensions.properties http://lxr.mozilla.org/seamonkey/source/browser/locales/en-US/chrome/browser/bookmarks/bookmarks.properties
http://lxr.mozilla.org/seamonkey/source/browser/locales/en-US/chrome/browser/migration/migration.properties

for other instances where switching to the other syntax and adding a comment for localizers seems appropriate.

(I found those from doing http://lxr.mozilla.org/seamonkey/search?string=%25S+%25S)
sorry for the bug spam, re-assigning bugs back to default owner if I'm not working actively on them.
Assignee: sspitzer → nobody
Product: Firefox → Toolkit
Duplicate of this bug: 412793
I've cleaned this up and added comments but didn't replace %S throughout. I think it should no longer be an issue for localizers with the added comments so resolving -> wfm
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.