Locale param for ja mac download different from the rest

RESOLVED INVALID

Status

defect
RESOLVED INVALID
13 years ago
6 years ago

People

(Reporter: sherman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
From: http://www.mozilla.com/en-US/firefox/all.html...

Is there a reason why the Japanese mac lang parameter in the download string is "ja-JP-mac" instead of simply "ja" ?
--> mozilla.org :: Build & Release
Assignee: nobody → build
Component: www.mozilla.com → Build & Release
Product: Websites → mozilla.org
QA Contact: www-mozilla-com → preed
Version: unspecified → other
(I have no idea. It's always been like this for me. Sending over to build for explanation. If something needs to be changed on the website, then please send it back to me.)
(Reporter)

Comment 3

13 years ago
Thanks Reed.

Comment 4

13 years ago
It's not just the lang parameter- the build itself is called ja-JP-mac.

Those in Japan who've been on the project longer than me have told me that for Firefox 1.0, there were 2 different Mac versions for ja. See:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0.8/mac

However, starting 1.5, there has only been 1 Mac ja version for official releases.  That has been the "ja-JP-mac" version.

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.5.0.7/mac

Note, that there are both "ja" and "ja-JP-mac" versions of nightly builds, but that should not be a concern here as we are focusing on "releases."

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2.0rc3-candidates/rc1

I've discussed this informally with dynamis, the ja localization manager, and he believes that there should be no issues with keeping the bits the same but re-naming the Mac Japanese version from "ja-JP-mac" to "ja."  However, we will need to put redirects in place and potentially there may be other impacts, so I want to make sure that  we all agree and move on an agreed-upon schedule.

Dynamis- if you have any comments, please let us know your thoughts or concerns.

My main concern is that we'll have a nightly called "ja" and a release called "ja" but they won't be the same (i.e. the "ja" release is really the "ja-JP-mac" whereas the "ja" nightly is really that- the "ja" nightly.)
(In reply to comment #0)

> Is there a reason why the Japanese mac lang parameter in the download string is
> "ja-JP-mac" instead of simply "ja" ?

I don't have all the details, but this is because on the Mac, there are some font problems with the standard ja locale (the strings fall off the page, etc.), so Mac effectively has its own locale, which is ja-JP-mac.

Is this causing issues with something that we can help with? I agree with Gen's concern that internally, the actual locale is ja-JP-mac, but the file would report itself as ja.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 6

13 years ago
dynamis- if you can add your opinion, we would appreciate it.
Assignee: build → nobody
QA Contact: mozpreed → build
Product: mozilla.org → Release Engineering
is still an issue with recent Mac ?
Japanese Mac builds have used the special ja-JP-mac locale so far. It's by design, not an issue.
You need to log in before you can comment on or make changes to this bug.