Trunk Oct 24 - Crashing when moving messages to trash

RESOLVED INVALID

Status

--
trivial
RESOLVED INVALID
12 years ago
11 years ago

People

(Reporter: robrackn, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060928 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060928 SeaMonkey/1.5a

When I checked email this morning using October 24 trunk build, I noticed the junk mail controls didn't tag all the messages. I was also unable to run the junk filters on an email folder.

When I went to manually click the 'junk' icon in the message column, the software crashed.

The message said: Unable to write the email to the mailbox. Make sure the file system allows you write privileges, and you have enough disk space to copy the mailbox.

Reproducible: Always

Steps to Reproduce:
1. click the 'check email' button and have a few ham and spam messages
2. set your junk mail settings to send files to 'junk' folder or 'trash' folder.
3. Click on the area where you can designate each message as 'junk' (the area where little recycle icon shows up in the message column).
Actual Results:  
Sea Monkey crashes. I get the message: unable to write the email to the mailbox. Make sure the file system allows you write privileges, and you have enough disk space to copy the mailbox.

Even after reverting back to the Sept 28 Trunk, the problem persists.

Expected Results:  
First, I would have expected junk controls to work as they always did.
Second, I would have expected the software could move messages to the 'junk' and 'trash' folder after designating it 'junk' and configuring the software to  move the message to the appropriate folder.

see attachments for crash log and system profile
(Reporter)

Comment 1

12 years ago
Created attachment 243468 [details]
Crash Log

This is the crash log from the October 24 Trunk build
(Reporter)

Comment 2

12 years ago
Created attachment 243470 [details]
My system profile

This is my system profile
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk

Comment 3

12 years ago
there don't seem t be symbols for the mail libraries, which makes the stack fairly useless :(.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> there don't seem t be symbols for the mail libraries, which makes the stack
> fairly useless :(.
> 

I've noticed there are other crash logs with other information in them.
The crash logs don't appear to have any consistent theme to them.
Is there more information you need from me? 
Would you like me to put up more crash logs?

Prior to reporting the bug, I repaired disk permissions. 
I actually just now reverted back to the August 22 release version but still have crashes and the same message pops up in the dialog box.

I've got plenty of disk space and permissions are supposedly set correctly now.

I'm currently using the October 25 trunk of Thunderbird to work with my emails now. Something completely toasted SeaMonkey.
Is there no Talkback in the SeaMonkey builds (under SeaMonkey.app/Contents/MacOS/components/Talkback.app I think)?
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)

I looked and I didn't see the Talkback.app insde the October 24 trunk or the August 22 release version.
I looked all in the SeaMonkey.app for it but couldn't find the Talkback.app
Yeah, the releases do not have Talkback. Bug 328854 is the reason why Talkback is disabled on trunk...
(Reporter)

Comment 8

12 years ago
(With regard to comment #0)
An update...

This bug will probably be nearly impossible to figure out so I wonder if I should leave it up, or at the very least, change the severity.  While it caused me an entire day of problems, I haven't seen any mention of this happening to anyone else thusfar. Perhaps it was simply coincidental.

I totally blew away the profile attached with the corrupted inbox on one of my accounts. I re-created a profile from a fresh install and copied the majority of mailboxes over to this new install. Things seem to be behaving so far. 

That has left a bit of uncertainty as to what caused the problem. However, things had worked perfectly for a very long time prior to installing the October 24 trunk.

I narrowed suspects down and it appears the inbox to my largest email account (1.45GB of stored messages) had become corrupt after launching the October 24 build. The inbox only had about 30 messages in it so it wasn't very big.

Anyhoo...
Things seem to be back to normal but I can't figure if the October 24 trunk caused the problem.
(Reporter)

Updated

11 years ago
Severity: critical → trivial
(Would have been "Incomplete", now is) R.Invalid, per comment 8.

Reopen if you can reproduce with SeaMonkey v2.0a1pre.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Keywords: crash
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.