bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Form elements appear purple in canvas after drawWindow

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cairo)

(Reporter)

Description

12 years ago
However now I can see things more clearly I can report an additional issue to
that of comment 17. Textboxes (multiline and single line) are just transparent
blocks, allowing whatever colour is underneath the canvas element to show
through. Any text in the textbox appears to get some kind of transform to its
colour, here my text is black in the webpage but in the canvas which has yellow
behind it the textbox appears yellow and the text a bright purple.
Interestingly as I increase the canvas size (hence reducing the scaling) the
textbox suddenly becomes light pink in background and the text remains purple.

See attachment 243536 [details].
(Reporter)

Updated

12 years ago
Whiteboard: cairo

Comment 1

11 years ago
See bug 324803, comment 19 for the source of the comment above.

Note, using 'Showcase' (http://showcase.uworks.net/), I can sort of reproduce the sidebar with the 'drawWindow' part, but I am not able to reproduce the Purple effect.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.