Closed Bug 358385 Opened 14 years ago Closed 14 years ago

New default Javascript settings in Firefox 2 break previously relied upon behaviour

Categories

(Firefox :: Preferences, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 355482

People

(Reporter: junkmail, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Upgrading from Firefox 1.5 to Firefox 2 broke several big sites that I own.

Investigation found "Preferences" / "Content" /Javascript "Advanced" / "Raise or lower windows" was un-ticked by default, therefore causing window.focus() not to work.

Scenario that this is a problem - a gallery page with enlarged versions of the pictures appearing in a pop-up. if user clicks the gallery page (causing the pop-up to disappear behind it), clicking another image will simply load the new requested content in a pop-up which remains hidden behind the main window, leading the user to believe the link is not working (despite a window.focus() in the javascript intended to bring the window to the front)

This breaks expected behavior that web designers have been able to rely on for about 10 years.

Reproducible: Always

Steps to Reproduce:
1. click link, opening javascript pop-up 
2. click main (opener) window to move it in front of the pop-up
3. click another link (opening content in a pop-up of the same window name)

Actual Results:  
pop-up remains hidden behind main window, leading user to believe link is broken.

Expected Results:  
javascript window.focus() function moves pop-up containing requested content into view.

This breaks expected behavior that web designers have been able to rely on since the early 90's. I have 2 big sites that rely on this default behavior and I know of several others that are similarly affected!

Was this release rushed out to match MSIE V7? I've spent several days trying to find a work-around for the above, in addition to finding workarounds to several irritating display bugs.

*** This bug has been marked as a duplicate of 355482 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.