Closed Bug 358585 Opened 14 years ago Closed 12 years ago

Spell checker in designMode is flaky

Categories

(Core :: Spelling checker, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ilkkah, Unassigned)

References

Details

(Keywords: testcase)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Here are a few test cases. What these have in common is document.open(), document.write() and document.close().

#1 Why only the first word is checked?
#2 When a stylesheet is linked, it will not work at all?
#3 When designMode is set on before document.open(), it seems not to work?

Reproducible: Always
Attached file Testcase #1
Attached file Testcase #2
Attached file Testcase #3
Assignee: nobody → mscott
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker
Version: unspecified → 1.8 Branch
Yeah it is a bug
Thanks for the great testcases, I think this is related to bug 357207.
Status: UNCONFIRMED → NEW
Depends on: 357207
Ever confirmed: true
Keywords: testcase
Version: 1.8 Branch → Trunk
Blocks: 424615
Assignee: mscott → nobody
The testcases works for me on - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090319 Shiretoko/3.5b4pre
WFM (Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99

Resolving.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.