Closed Bug 358732 Opened 13 years ago Closed 13 years ago

Crash in _moz_cairo_win32_scaled_font_select_font, part 2

Categories

(Core :: Graphics, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: martijn.martijn, Assigned: martijn.martijn)

References

()

Details

(Keywords: crash, testcase)

Attachments

(4 files)

Bug 356400 was a bug that also crashed in with this stacktrace.

See upcoming testcase.
Because of the use of enhanced privileges, you need to download the testcase locally.

Talkback ID: TB25246360Z
_moz_cairo_win32_scaled_font_select_font  [mozilla\gfx\cairo\cairo\src\cairo-win32-font.c, line 1618]
Attached file testcase
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061030 Minefield/3.0a1

Works for me on Linux trunk, for what it's worth.
Flags: blocking1.9?
(In reply to comment #3)
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061030
> Minefield/3.0a1
> 
> Works for me on Linux trunk, for what it's worth.
> 
I'd bet money based on the win32 in |_moz_cairo_win32_scaled_font_select_font| function call that you wouldn't see this on linux...
WFM on Windows XP with a current trunk build.
Not for me, testcase still crashes, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061124 Minefield/3.0a1
Martin, does this still crash for you with a build containing the patch for bug 362068?
Yes, unfortunately, I still crash with a 2007-01-03 build, talkback ID: TB27990834X
Still crashing, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070131 Minefield/3.0a2pre
Attached image testcase2
This testcase crashes directly for me when visiting, talkback ID: TB28884798G
_moz_cairo_win32_scaled_font_select_font  [mozilla\gfx\cairo\cairo\src\cairo-win32-font.c, line 1620]
gfxWindowsTextRun::Draw  [mozilla\gfx\thebes\src\gfxwindowsfonts.cpp, line 696]
gfxWrapperTextRun::Draw  [mozilla\gfx\thebes\src\gfxwindowsfonts.cpp, line 647]
nsThebesRenderingContext::DrawStringInternal  [mozilla\gfx\src\thebes\nsthebesrenderingcontext.cpp, line 1318]
nsRenderingContextImpl::DrawString  [mozilla\gfx\src\shared\nsrenderingcontextimpl.cpp, line 893]
nsTextFrame::PaintUnicodeText  [mozilla\layout\generic\nstextframe.cpp, line 2977]
Crashing with current nightly build on:
http://www.jalsoe.dk/

TB29965138E

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070305 Minefield/3.0a3pre ID:2007030504 [cairo]
Ok, the testcases are wfm, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070317 Minefield/3.0a3pre
Henrik, do you still crash at http://www.jalsoe.dk/ with the latest nightly trunk build?
(In reply to comment #12)
> Ok, the testcases are wfm, using:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070317
> Minefield/3.0a3pre
> Henrik, do you still crash at http://www.jalsoe.dk/ with the latest nightly
> trunk build?
> 

I'm no longer crashing. I think this bug is a dupe of a bug that got fixed last week. cant remmeber the bug number
Ok, this got fixed somehow between 2007-03-04 and 2007-03-05:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-03-04+04&maxdate=2007-03-05+09&cvsroot=%2Fcvsroot
I think somehow fixed by bug 370588.
However, the " iframe needed for testcase" doesn't show the squares anymore I used to see. So that may actually be a bug. Opera9 and IE7 do show the squares.
I suspect that as soon the squares will be rendered again, the testcases will crash again.
Assignee: general → nobody
Component: SVG → GFX: Thebes
Depends on: 370588
QA Contact: ian → thebes
Attached file testcase 3
Ok, this is a testcase that still crashes with this stack trace in current trunk build.
It uses enhanced privileges, so you need to download the testcase to your computer. Most of the time, it crashes within 5 seconds for me.
I'm also noticing some severe slow-down and 100% cpu when this testcase is first shown.
The final testcase is something different because there is no SVG in it as far as I can see. I would recommend you close this bug, probably as WORKSFORME since the original testcases are now OK and raise a new problem on the correct component.

FWIW I would guess the crash occurs when you set the textzoom to 0.
Ok, marking as worksforme, I filed bug 374949 as a follow-up.

I guess the issue of the missing squares mentioned in comment 14 is bug 372732.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Flags: blocking1.9?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.