Closed Bug 358741 Opened 13 years ago Closed 13 years ago

Crash [@ nsListBoxBodyFrame::GetListItemContentAt]

Categories

(Core :: XUL, defect, critical)

x86
All
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: smaug, Assigned: smaug)

References

Details

(Keywords: verified1.8.0.9, verified1.8.1.1)

Attachments

(3 files, 1 obsolete file)

TB shows some crashes @ nsListBoxBodyFrame::GetListItemContentAt.
I think the binding parent is null.
Typical stack trace:
nsListBoxBodyFrame::GetListItemContentAt  [mozilla/layout/xul/base/src/nsListBoxBodyFrame.cpp, line 1389]
nsListBoxBodyFrame::GetFirstItemBox  [mozilla/layout/xul/base/src/nsListBoxBodyFrame.cpp, line 1143]
nsListBoxBodyFrame::CreateRows  [mozilla/layout/xul/base/src/nsListBoxBodyFrame.cpp, line 1032]
nsListBoxBodyFrame::ReflowFinished  [mozilla/layout/xul/base/src/nsListBoxBodyFrame.cpp, line 503]
Attached patch possible patch (obsolete) — Splinter Review
Need to still think a bit whether this makes sense :)
Assignee: nobody → Olli.Pettay
Status: NEW → ASSIGNED
Version: 1.8 Branch → Trunk
Attachment #244088 - Attachment description: testcase → testcase (crashes on load)
Attached patch proposed patchSplinter Review
The 5th code hunk is just adding one new |if| around if-else. Otherwise
changes look as simple as they are.
Attachment #244085 - Attachment is obsolete: true
Attachment #244090 - Flags: review?(enndeakin)
Attachment #244090 - Flags: review?(enndeakin) → review+
Attachment #244090 - Flags: superreview?(roc)
Flags: blocking1.8.1.1?
Attachment #244090 - Flags: superreview?(roc) → superreview+
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Attachment #244090 - Flags: approval1.8.1?
Attachment #244090 - Flags: approval1.8.0.9?
Attachment #244090 - Flags: approval1.8.1? → approval1.8.1.1?
Flags: blocking1.8.1.1?
Flags: blocking1.8.1.1+
Flags: blocking1.8.0.9+
Comment on attachment 244090 [details] [diff] [review]
proposed patch

approved for 1.8/1.8.0 branches, a=dveditz for drivers
Attachment #244090 - Flags: approval1.8.1.1?
Attachment #244090 - Flags: approval1.8.1.1+
Attachment #244090 - Flags: approval1.8.0.9?
Attachment #244090 - Flags: approval1.8.0.9+
*** Bug 321016 has been marked as a duplicate of this bug. ***
fixed1.8.0.9, fixed1.8.1.1
Verified Fixed for 1.8.0.9 and 1.8.1.1.
No Crash on Testcase

Tested with 
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.1pre) Gecko/20061127 BonEcho/2.0.0.1pre
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.1pre) Gecko/20061127 BonEcho/2.0.0.1pre

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.0.9pre) Gecko/20061127 Firefox/1.5.0.9pre
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.0.9pre) Gecko/20061127 Firefox/1.5.0.9pre

and Fedora FC6
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9pre) Gecko/20061127 Firefox/1.5.0.9pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1pre) Gecko/20061127 BonEcho/2.0.0.1pre
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.