RTL mode breaks links in some situations

RESOLVED DUPLICATE of bug 299065

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 299065
11 years ago
10 years ago

People

(Reporter: Ben Kamens, Unassigned)

Tracking

({rtl})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Repro HTML:
"<span><a href="www.google.com">&#1488;&#1493;&#1500;&#1497; &#1488;&#1514;/&#1492; &#1502;&#1499;&#1497;&#1512;/&#1492; &#1496;&#1499;&#1504;&#1488;&#1497; &#1492;&#1511;&#1500;&#1496;&#1493;&#1514; &#1488;&#1493;&#1500;&#1508;&#1503;? </a></span><span>&#1488;&#1493;&#1500;&#1497; &#1488;&#1514;/&#1492; &#1502;&#1499;&#1497;&#1512;/&#1492; &#1496;&#1499;&#1504;&#1488;&#1497; &#1492;&#1511;&#1500;&#1496;&#1493;&#1514; &#1488;&#1493;&#1500;&#1508;&#1503;?</span>"

Insert this legit HTML into the document.  Notice that the nodes are (appropriately) rendered in RTL mode, except for the ? question mark at the end of the second span, which is placed to the right of the <a> node.

This also creates the more serious problem that the text of the link is not clickable (but notice that the underlined text-decoration is still clickable).

Reproducible: Always

Steps to Reproduce:
1. Described above, just paste the HTML into a document and notice that the link cannot be clicked.

Actual Results:  
Can't click link

Expected Results:  
Be able to click the link, and the question mark should be rendered w/in the appropriate node.
(Reporter)

Comment 1

11 years ago
Also occurs in FF 1.5
To display correctly in RTL mode with the question mark at the left side of the text you need to add dir="rtl" to the HTML source.

The problem with the link is fixed in trunk builds by bug 299065.

*** This bug has been marked as a duplicate of 299065 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Comment 3

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.