Closed Bug 358775 Opened 13 years ago Closed 13 years ago

Print function is broken

Categories

(Calendar :: Printing, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: omarb.public, Assigned: mattwillis)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1) Gecko/20061010 Firefox/2.0

Print function doesn't work

Reproducible: Always

Steps to Reproduce:
1.Press ctrl+p
2.Compare print a calendar window with list of events





Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061030 Calendar/0.4a1
Attached image Screenshot
I can see an error:

Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/printDialog.js :: loadCalendarPrintDialog :: line 74"  data: no]
I think it's caused by patch in bug 332063
calWeekPrinter.js wasn't added to packages-static.
Fix forthcoming.
Assignee: nobody → lilmatt
Blocks: 332063
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Attachment #244105 - Flags: first-review?(mvl) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
WFM with today night build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.